Support » Plugin: Participants Database » Thanks Page not refreshing

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author xnau webdesign

    (@xnau)

    First, check that you’re using the latest version of Participants Database.

    OK, so is it still necessary to use the “alternate php session method” setting? If not, unchecking that should solve your problem.

    I tried testing your scenario, and I was not able to duplicate the problem. I would suggest you look at the URL you are using for them to create a new record, make sure it does not contain the “sess” value. However, the plugin should not resend the email or display the previous record values even if you re-use the session value in the URL, so I’m not sure what is happening in your case.

    If there is anything that might be interfering, it would be another plugin that is using sessions.

    Karen Turner

    (@karen-turner)

    Hi Thank you for your reply.

    I am still experience a major problem and am completely stumped as to what to try next.

    The problem:
    On the sign up page I have the [pdb_signup] short code
    On the Thank you page I have the [pdb_signup_thanks] short code
    in the signup form settings I have set the sign up thanks page

    A link on the menu goes to the signup page and the submit takes you to the thanks page. A message with the access link gets sent and the thank you message is displayed

    ALL good.

    Then click link to signup page again for a new participant.
    The url says signup page, but the page displayed is the previous thank you page.
    Another email link goes out the same as the previous one, with corresponding messages to say a new participant has been added. If you click edit page, it is in fact the signup page, not the thank you page.

    Extremely bizarre

    I have:
    reinstalled WordPress 5.3.2
    Disabled all plugins
    Changed theme
    Rolled WordPress back to 5.2
    Rolled participants database back to 1.9.4

    updated WordPress back to 5.3.2
    updated participants database back to 1.9.5.5
    changed the permalinks and changed them back

    made new signup and thank you pages

    Can you think of any reason this could be happening. I have been using the participants database for maybe 3-4 years and it has been fine up until now. I haven’t changed anything that I can think of.

    It would seem that the signup somehow not resetting the submit button.

    Any ideas would be gratefully appreciated.

    Thank you

    Plugin Author xnau webdesign

    (@xnau)

    Are you using a caching plugin? You should disable page caching on the signup and thanks pages.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.