Support » Plugin: Vrm 360 3D Model Viewer » Textures and materials not displaying

  • Resolved offworld21

    (@offworld21)


    Hi maui2wp,

    Firstly thank you for the great plugin – I know if I can get it configured it’s going to be awesome!

    I’m having an issue with the obj file loading without the textures or materials. I first tried uploading the obj, mtl and png textures through the WordPress media library, however, nothing would show except the spinning wheel. I then deleted all the files from the media library and uploaded a seperate folder through FTP to the ‘wp-content/uploads’ folder and can now get the model to show by using the full url path. The issue is that the wireframe has been ‘redrawn’ and none of the textures are displaying.

    This is what the 3D object should look like: /elephant_textures/

    This is what the wirefrome looks like on Blender: /elephant_wireframe/

    This is what the wireframe looks like once uploaded and viewed via shortcode: /elephant_wireframe2/

    The uploaded obj wireframe has also had additional paths added which you can see here: /elephant_wireframe3/

    Please let me know if you require any further information.

    Many thanks in advance

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author maui2wp

    (@maui2wp)

    Hi @offworld21
    Could you post your ‘.obj’ and ‘.mtl’ file here or as an external link, so I can try it?
    Maurice

    Thread Starter offworld21

    (@offworld21)

    Hi Maurice,

    Thanks for getting back to me.

    I’ve zipped up the mtl, obj and texture png files, you can download them here: https://www.dropbox.com/s/d409bv8krz946m2/elephant.zip?dl=0

    Please let me know if you need anything else.

    Thanks again 🙂

    Plugin Author maui2wp

    (@maui2wp)

    Hi @offworld21
    thanks for the files…
    What I did to display your model is:
    1) resize each of your texture from 4096×4096 to 1024×1024 reducing their size from 12MB each to 1.4MB each (NB that also will decrease the model loading time)
    2) export your file from Blender (2.79b) as obj (I did not used wireframe)
    3) zip all your files to a single file (NB don’t include the folder in the zip)
    4) point to the zip file in your shortcode
    something like this
    [vrm360 canvas_name=3d3 model_url=https://www.yoursite.com/wp-content/uploads/2019/06/elly.zip aspect_ratio=1.3 speed=1 autostart=true initial_offset=1.8]

    and here the zipped file
    (inside there is also a screenshot of blender export settings)
    https://send.firefox.com/download/dfbcb136e3d7685a/#bwT6DnKL_UWP4dgOUj-s_Q

    BTW would you consider to review my plugin?
    https://wordpress.org/support/plugin/spin360/reviews/?rate=5#new-post
    😉

    • This reply was modified 1 year, 10 months ago by maui2wp.
    Thread Starter offworld21

    (@offworld21)

    Maurice,

    Thank you so much for looking into this for me and the speedy resolution! Very much appreciated 🙂

    Unfortunately when I click the link above I get a ‘Link expired’ notice. Are you able to resend it or do you have Dropbox?

    I will be most happy to review your plugin, thanks again 🙂

    Plugin Author maui2wp

    (@maui2wp)

    Thread Starter offworld21

    (@offworld21)

    Hi Maurice,

    Thank you for your help, the zip file worked like a treat 🙂

    I looked at the settings you used and they were exactly the same as what I used to export, so I inspected the mtl and obj files and saw that mine had the absolute path to the textures files such as c:\My Documents\meshroom\texture_0.png whereas the mtl and obj files in your zip file didn’t. I edited these files with two other models and they now work too 🙂

    I have encountered another issue now though. If more than one model is viewed all models after the first one is viewed seem to use the texture files from the first model. For example, if I view the model at /photogrammetry/mabel then view /photogrammetry/elephant or /photogrammetry/mycomorph, the two following models use the textures from the first model. I though at first this was just my caching plugin so I disabled it and it still happens. I then cleared the web browser cache and this resolved it.

    It would seem VRM 360 is using the texture files in the browser cache because they have the same name for each model (texture_0.png, texture_1.png..) which is how Blender names them. Is there a way for VRM 360 to reference the correct texture files or do all of the texture files need to have unique names, even though they’re in different zip files?

    I hope this all makes sense! If you need to see what is happening visit one of the links above then go to another and you’ll see the texture files being reused.

    Once again, thank you for your help.

    Plugin Author maui2wp

    (@maui2wp)

    @offworld21

    It would seem VRM 360 is using the texture files in the browser cache because they have the same name for each model (texture_0.png, texture_1.png..) which is how Blender names them. Is there a way for VRM 360 to reference the correct texture files or do all of the texture files need to have unique names, even though they’re in different zip files?It would seem VRM 360 is using the texture files in the browser cache because they have the same name for each model (texture_0.png, texture_1.png..) which is how Blender names them. Is there a way for VRM 360 to reference the correct texture files or do all of the texture files need to have unique names, even though they’re in different zip files?

    You can simply open your ‘.mtl’ file in a text editor and change the texture png filenames to create a unique name for each model…
    ie.

    # Blender MTL File: 'None'
    # Material Count: 9
    
    newmtl TextureAtlas_0
    Ns 0.000000
    Ka 0.600000 0.600000 0.600000
    Kd 0.600000 0.600000 0.600000
    Ks 0.000000 0.000000 0.000000
    Ke 0.000000 0.000000 0.000000
    Ni 1.000000
    d 1.000000
    illum 2
    map_Kd texture_elephant_0.png
    
    newmtl TextureAtlas_1
    Ns 0.000000
    Ka 0.600000 0.600000 0.600000
    Kd 0.600000 0.600000 0.600000
    Ks 0.000000 0.000000 0.000000
    Ke 0.000000 0.000000 0.000000
    Ni 1.000000
    d 1.000000
    illum 2
    map_Kd texture_elephant_1.png

    then rename the texture files accordingly

    texture_elephant_0.png
    texture_elephant_1.png
    • This reply was modified 1 year, 10 months ago by maui2wp.
    Thread Starter offworld21

    (@offworld21)

    Hi Maurice,

    Once again thank you for your speedy reply! I’ve given all of the texture files unique names and it’s all working correctly. It’s no big deal to rename any future model texture files and will prevent the browser from using same name cached files.

    Now about to leave you a review, thanks again Maurice and have a wonderful week!

    Plugin Author maui2wp

    (@maui2wp)

    Hi @offworld21
    I gave you a wrong link for the review… in the previous reply The link is for the other mine twin plugin, for photography turntable.
    Here the correct link
    https://wordpress.org/support/plugin/vrm360/reviews/?rate=5#new-post

    Sorry for any inconvenience and thanks again for the review

    • This reply was modified 1 year, 10 months ago by maui2wp.
    • This reply was modified 1 year, 10 months ago by maui2wp.
    Plugin Author maui2wp

    (@maui2wp)

    I’m closing it as solved.

    Maurice

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Textures and materials not displaying’ is closed to new replies.