Support » Plugins and Hacks » Text links save but then disappear

Text links save but then disappear

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Danny van Kooten


    Hi ottomek,

    Does this behaviour happen when editing normal posts or pages? Most likely some other plugin is conflicting because absolutely nothing is different from creating normal posts or pages. The new plugin consists of only native WordPress functions.

    Hope you can figure it out.


    I have WP 3.5, WYSIWYG Widgets 2, and Ultimate TinyMCE (latest version), and I replicated what you posted ottomek, but all links are there and work fine.

    Yes I checked and links are staying active in pages just not in WYSIWYG 2.
    TinyMCE Advanced 3.5.8
    WP 3.5
    Dynamic Widgets 1.5.4

    Danny, if you are not able to replicate this could I PM you temporary login to my site and check it out?

    Plugin Author Danny van Kooten


    Hi ottomek,

    Tried as soon as you posted this topic, wasn’t able to replicate it either. So sure you can, I’ll be glad to dig into it to see if anything needs to be fixed in my plugin. You can e-mail me at hi@dannyvankooten.com.



    Titles of the Widget appear at the bottom of the text.
    How can I resolve it?


    Plugin Author Danny van Kooten


    Hi camperlife,

    Got a (live) example of this behaviour? It probably has something to do with your theme’s CSS.



    I found it’s TinyMCE Advanced v3.5.8 that is causing the links to not save in WYSIWYG Widgets 2. Links still save in Post & Pages with TinyMCE though.

    And specifically when I have the TinyMCE setting of “Stop removing the <p> and
    tags when saving and show them in the HTML editor” selected this prevented links from being saved, when I unchecked this links would save in WYSIWYG 2.

    Thoughts? Thanks.

    I found a little more info and not sure if it’s a TinyMCE issue. When I use visual editor to highlight text and make a link the link gets put outside the <p> tags (when I switch to html view). See example below.

    <p>Link Text </p>

    This was occurring with other pages too not just WYSIWYG widget. I can make it work now.

    Hi There,

    Just seen this thread. I am experiencing the same issues with TinyMCE 3.5.8. What happens is I highlight the text I want to add the link to, insert the link then when I switch to the text tab, I can see that the link is wrapped around the <p> tag. If I publish this without changing the code (as an editor without HTML knowledge would), the link works fine on the front end but when the editor goes back to the page, the link has dissappeared! Pressumably this is because TinyMCE is seeing it as invalid (which it is) and stripping it out. The problem is that TinyMCE is causing the invalid code in the first place.

    This is causing me some headaches because obviously the editors of the sites I build are not capable of editing the HTML to correct the original issue. I’d be happy to demonstrate this over a ‘join.me’ session with the plugin author if needed?


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Text links save but then disappear’ is closed to new replies.