Support » Plugin: ACF Content Analysis for Yoast SEO » Text length: The text contains 0 words.

  • Eva

    (@jesuiseva)


    My ACF content doesn’t seem to get analysed. I get the message:

    Text length: The text contains 0 words. This is far below the recommended minimum of 300 words. Add more content.

    There actually is content over multiple fields. So I wonder if i’m missing something?

    WordPress: Version 5.3.2
    ACF Content Analysis for Yoast SEO: Version 2.6
    Yoast SEO: Version 14.8.1

    • This topic was modified 1 month, 3 weeks ago by Eva.
Viewing 10 replies - 16 through 25 (of 25 total)
  • jamergin

    (@jamergin)

    @danailiescu apologies for the delay.

    SEO performance:
    It took us a few days to notice the issue but thankfully there has been no change in performance.

    Downgrading:
    Downgrading is not optimal but, if it works, it’s better than broken features that are potentially harmful to site performance or hinder UX.

    To downgrade, I used the WP CLI to rollback the plugin versions, but there is another way if that’s not an option:

    1. download the previous version of the plugin. You can usually get the previous version by modifying the plugin download path e.g.

    2. Deactivate and uninstall the existing plugin
    3. Install using the downloaded zip of the plugin version you desire and activate
    4. Test the updates

    Hope this helps!

    danailiescu

    (@danailiescu)

    @jamergin thanks a lot for your reply! I will give it a try then with the steps you provided.

    See this GitHub issue – seems to be connected to using classic editor (which I am because I use it for flexible content fields). I remember there was a similar issue a while back.
    In the GitHub issue there’s also a code snippet for a workaround via functions.php.

    Hi @everyone,

    There is a temp solution on the plugin github repo:

    add_filter('admin_enqueue_scripts', function() {
        $yoast_acf_analysis_plugin_data = get_plugin_data( AC_SEO_ACF_ANALYSIS_PLUGIN_FILE );
        $config = Yoast_ACF_Analysis_Facade::get_registry()->get( 'config' );
    
        // Post page enqueue.
        if ( wp_script_is( WPSEO_Admin_Asset_Manager::PREFIX . 'post-edit-classic' ) ) {
            wp_enqueue_script(
                'yoast-acf-analysis-post',
                plugins_url( '/js/yoast-acf-analysis.js', AC_SEO_ACF_ANALYSIS_PLUGIN_FILE ),
                [ 'jquery', WPSEO_Admin_Asset_Manager::PREFIX . 'post-edit-classic', 'underscore' ],
                $yoast_acf_analysis_plugin_data['Version'],
                true
            );
    
            wp_localize_script( 'yoast-acf-analysis-post', 'YoastACFAnalysisConfig', $config->to_array() );
        }
    }, 20, 0);

    https://github.com/Yoast/yoast-acf-analysis/issues/272

    I disabled the Classic Editor plugin altogether, but the issue still persists.

    • This reply was modified 3 weeks, 6 days ago by danailiescu.

    joining this thread for followup comments

    Thanks, @nunosarmento. Confirming this workaround has enabled us to run the latest versions of both plugins on WordPress 5.5.1.

    Finaly an update that solved this issue! Updated to latest versions (2020-09-30)
    ACF Content Analysis 3.0
    ACF 5.9.1
    Yoast SEO Premium 15

    Wordcount – works!!

    Thanks for the heads up, @moztwanted! I can confirm updating to the latest version has worked for us also and after removing any previous workarounds.

    As per their release notes:

    3.0.0

    Released September 29th, 2020

    Bugfixes:

    Fixes a bug where the content of ACF fields wouldn’t be included in the SEO and readability analysis when using the Classic Editor plugin.
    Fixes a bug where changes to the content of ACF fields wouldn’t trigger a live refresh of the SEO and readability analysis.

    Thank you for posting here, @moztwanted! Works for us too. 🙂

Viewing 10 replies - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.