Text is not wrapping (7 posts)

  1. mhanson3
    Posted 3 years ago #


    Text is not wrapping. I've tried several themes, they all do the same thing. The code looks correct (alignment). Any suggestions?



  2. alchymyth
    Forum Moderator
    Posted 3 years ago #

    interestingly, you are using   'non-breaking-space' characters in your test content; on purpose or by mistake (?)

    example: Testing Testing Testing Testing Testing 

    and these are doing what they are meant to do - i.e. not breaking.

    try and use a 'normal' sample content to test themes, such as 'lorem ipsum'.

  3. mhanson3
    Posted 3 years ago #

    I'm basically typing it directly into the WordPress visual editor. Not importing it, just typing it directly into the app.

  4. David Laietta
    Posted 3 years ago #

    While something like word-wrap: break-word; could momentarily fix your problem, it's not anywhere near an ideal solution.

    When using the visual editor, do you have it set to Visual or HTML? When live editing the code of your site and adding in some filler text in place of the Testing, I see that it is breaking properly. As alchymyth has pointed out above, you are using   in your text. As the name implies, it is non-breaking, meaning it will continue to go until a break is found.

    You mentioned that it happens with each theme that you tried, so my guess is just in how you copied and pasted the testing in. I see on other posts that other text properly breaks.

  5. alchymyth
    Forum Moderator
    Posted 3 years ago #

    did the problem start after an update?
    or is this a new install?

    seems to be caused by the editor tinyMCE; however, unfortunately, I have no idea what causes it and how to solve it.


    in extreme, consider to re-install the full WordPress installation.

  6. mhanson3
    Posted 3 years ago #

    Went in, deleted the first test post, created a 'test2' post. In this one, used the option of pasting as text. That seems to work. But sort of odd that I can't type it directly into the tool, isn't it?

  7. mhanson3
    Posted 3 years ago #

    New installation. In fact, I've already uninstalled and reinstalled it once. Problem remains.

Topic Closed

This topic has been closed to new replies.

About this Topic