Support » Plugin: Smart Slider 3 » Text in your sample doesn’t stay aligned

  • Resolved designdrumm

    (@designdrumm)


    Hello,
    Small problem. Hoping you can help.
    Text in your sample doesn’t stay aligned. I used the sample to create my slide from. It is currently set to the center of the slide, but when viewed, it is off by a lot. One slide’s text is off the edge of the slide! Yikes!

    I cleared my cache, moved the text then moved it back and saved. The first view after that, it was centered. Then I proceeded to change the name of the slide. Saved and all text boxes were misaligned again.

    Not sure what is going on. Any thoughts?

    http://designdrumm.com/wordpress

    Slider at the bottom by footer.

    TIA,

    Best,
    designdrumm

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @designdrumm

    Are you possibly using Safari 10+? We’ve recently encountered a bug with that browser related to the way it loads the fonts, which seemed to address the problems with the text positions. Unfortunately this fix wasn’t released yet and we’re currently out of the office for a national holiday today, so I can’t check it for sure if that’s your problem as well. (On my Firefox 43 and Chrome 58.0.3029.81 everything looked fine.)

    If you drop me an e-mail to support@nextendweb.com referring to this topic I’ll send you the latest build tomorrow (which we can hopefully release soon) to see if it solves your problem as well.

    designdrumm

    (@designdrumm)

    Hi Ramona,
    I am using Safari Version 10.1 (11603.1.30.0.34).
    Just now when the site loaded, it worked as expected.
    I will have to test again to see if it breaks.

    Personally, I don’t think that my issue is related to fonts loading.
    I think it has to do with the organization of things being floated or how the x and y are calculated and applied on load or how the x and y are stored for reference on the front end. Is your plugin caching things on its own? This may be the cause as well since it seems to clear when the layout is edited, but not if the slide settings are saved. Might have a look at the code that actually saves the layout data into the database. It may be garbling data. Is your code set to UTF-8?

    I will email you after this. Thanks for your help.

    Best,
    designdrumm

    designdrumm

    (@designdrumm)

    Hello again,
    I haven’t been able to replicate since the update, so maybe that fixed it? If it happens again, I will open another ticket, but I’m calling this one fixed for now. Thanks for the speedy response!

    Best,
    designdrumm

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @designdrumm

    I’m glad it worked out 🙂 Yes, the update fixed the problem as it was happening because of the way Safari 10+ loads the fonts.

    Before the position calculations would start by the slider, it reaches out to the browser to see if it has loaded all the needed resources (CSS, JavaScript files and fonts) and Safari 10+ tells the code that it has finished loading the needed fonts, when in fact, it hasn’t. This causes the layers to move out of place when the fonts are actually loaded. (As with the texts and fonts inside the layers, they’re much bigger.)

    The fix will be in the next versions as well, which we can hopefully release soon.

    Hello again,
    Had to reopen this one, the slider is still not honoring the text layout.

    I have since went with an all image slide (where my text is part of the image) which works well except on mobile devices. Seems that when an image is a rectangle, your slider wrappers have a preset height that keeps the slider as a square on mobile devices. From what I have experienced. Does not let it wrap to its contents.

    Is there any way you could add the ability to enter “auto” as a height for slides?
    That would fix my issue immediately. Please let me know. Thank you.

    Look forward to your reply.

    Best,
    designdrumm

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @designdrumm

    In Content mode: https://smartslider3.helpscoutdocs.com/article/1430-tutorial-video-content-mode
    the slider height adjusts to the height of the slide content. (It applies for layers only, so slide background images doesn’t affect it.)
    This mode also solves the font loading problem in Safari.

    Hi Ramona,
    I checked again on the text layout and it does seem to be working now.
    Also, it looks like I had background images set to center instead of fit or fill.
    So sorry for the false alarm. Thank you for your awesome support!

    Best,
    designdrumm

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Text in your sample doesn’t stay aligned’ is closed to new replies.