Text Editor is gone after 3.9 (14 posts)

  1. Remusco
    Posted 1 year ago #

    after updating to 3.9 today the text editor is gone. I see only "Add Media" button and a square text field. Please advice.

  2. Can you try disabling all of your plugins to see if there's a conflict? Once you've done that please clear your browsers cache and cookies, re-login and try again.

  3. Remusco
    Posted 1 year ago #

    I have done it as you advised. Did not help.

  4. Next thing to try is to temporarily switch your theme to the Twenty Fourteen theme. Once again, clear your browser cache and re-login. See if that solves it for you.

    If that doesn't work can you try these instructions to see if there is a JavaScript conflict?


    It could be a JavaScript issue interfering with the Visual Editor.

  5. I'm having the same issue-- no visual editor after upgrade to 3.9

    I've deactivated all plugins & switched to Twenty Fourteen-- issue persists.

    I tried the browser consoles as suggested: it showed error: "TypeError: r is undefined wp-tinymce.php:9"

    Not sure what that means. Remusco, did you get the same error?

  6. Hey Bet, try downloading WordPress 3.9, unzip it and then upload all of the files to your web server, overwriting the existing files. Let us know if the problem still persists.

  7. I downloaded 3.9 and overwrote existing files (except for wp-content-- just like a manual upgrade). No change.

    I don't know how important this is, but this is a multisite install with over 55 sites, only 10 of which are affected with missing TinyMCE. Maybe that will help us narrow down the issue, since all these sites share the same core wp files.

    I've tried to think about what is unique to these sites, but I can't come up with anything: They are a mix of older and newer sites, a mix of themes (I mostly use ithemes' Builder, but some of them the 10 are older, other themes), and there is no plugin active on these sites that isn't also active on an unaffected site.


  8. Bet, can you please create a new forum thread explaining your issue in detail, including the Multisite factor. It will help us concentrate on your specific problem.

  9. therbert1234
    Posted 1 year ago #

    Hi, I have also updated to 3.9 today and my text editor is also gone. I have tried the suggestions above but with no luck. Has anyone got a fix for this please.

  10. therbert1234 - Same thing. Please make your own post.

    List what you've tried (you said you tried the 'above suggestions' but it really helps us if you list exactly what you tried). Make sure you've also tried the basics:

    • flushing any caching plugins you might be running, as well as server and/or browser caches.
    • deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read "How to deactivate all plugins when you can't log in to wp-admin" if you need help). Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old
    • switching to the Twenty Fourteen theme to rule out any theme-specific problems. If you can't log in to change themes, you can remove the theme folders via FTP so the only one is twenty fourteen. That will force your site to use it.
    • manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.5 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first.
  11. Remusco
    Posted 1 year ago #

    I have tried the following:
    1. deactivated all plugins
    2. cleared all cache and cookies
    3. re-logged in
    4. switched theme to to the Twenty Fourteen
    5. re-logged in again
    6. switched back to my theme

    did not work

  12. @Remusco: have you tried the suggestion to look for JavaScript errors?

    This post's instructions are a little dated, but you can google more updated instructions for the browser you are using. I found more detail on the errors using Chrome than other browsers.

  13. Jaidev Pandit
    Posted 1 year ago #

    Hello guys I have tried all the above methods but none of them worked. Kindly resolve this as soon as possible as it is affecting my work.

  14. keesiemeijer
    Posted 1 year ago #

    @Jaidev Pandit - Same thing. Please make your own post.

    List what you've tried (you said you tried the 'above suggestions' but it really helps us if you list exactly what you tried).


Topic Closed

This topic has been closed to new replies.

About this Topic