Support » Fixing WordPress » Text editor extremely slow

  • Resolved salromano

    (@salromano)


    Upgraded to 4.2 today, and then immediately to 4.2.1 (it came out literally the hour I finished upgrading to 4.2). Is there something wrong with the text editor? It’s extremely slow now versus the very fast visual editor. I can’t even use it anymore for text-heavy articles.

Viewing 15 replies - 1 through 15 (of 41 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Nothing changed that would affect that between 4.2 and 4.2.1.

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Fifteen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    I have also noticed that since updating WordPress, when typing a post in text editor mode, it is painfully slow.

    Sometimes I can finish typing whole sentences before the first letter of the first word appears on the screen.

    It’s not my computer, my computer is very fast and it’s a clean install of Chrome, so no bugs there. I’m convinced it’s WordPress.

    Very annoying.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    If the troubleshooting already posted made no difference for you, please open your own thread: https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    I have now worked out the culprit. It is the stupid introduction by WordPress of Emoji support which loads scripts and who knows what else.

    I copied and pasted the code at the following link into my WordPress theme’s functions.php file and the text editor now works a treat, just like it used to:

    http://wordpress.stackexchange.com/questions/185577/disable-emojicons-introduced-with-wp-4-2

    Those with less technical ability, the code at that page disables Emoji support – and stops the scripts etc loading, it is not harmful to your site in any way whatsoever.

    If you’re not able or condfident to edit your functions.php file, I suggest you install a plugin to disable Emoji which will do exactly the same thing as copying and pasting that code into your theme’s functions.php file.

    Here is one you may wish to install: https://wordpress.org/plugins/disable-emojis/

    I’m confident you will be able to use the text editor without any latency after that.

    It’s a shame WP released this version with a bug (it’s a shame they introduced Emoji support in the first place in my opinion) but even if they don’t come up with a fix for it, disabling Emoji support is no bad thing – it slows down page loading times among other things.

    Good riddance to it I say! I hope my post helps somebody!

    Oh, and @JamesHuff, I found your comments to be premature.

    You were the only person to have responded to the OP before I posted my comment, following which you – in couched terms – suggested that it wasn’t really appropriate for me to have commented.

    All I can say is, your comment offered absolutely no help whatsoever. Mine, however, I hope, has done.

    Thread Starter salromano

    (@salromano)

    Thank you so much, rowd1951! The functions.php edit did the trick!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    It is the stupid introduction by WordPress of Emoji support which loads scripts and who knows what else.

    I believe you mean the introduction by WordPress of support for native Chinese, Japanese, and Korean characters, which also happens to include support for Emoji.

    I copied and pasted the code at the following link into my WordPress theme’s functions.php file and the text editor now works a treat

    Use the plugin, it’s safer then adding a hack that hasn’t been reviewed by the core or plugin teams: https://wordpress.org/plugins/disable-emojis/

    It’s a shame WP released this version with a bug

    It’s not a bug, the editor shouldn’t be operating slowly, but it’s a shame you’d rather not help us troubleshoot to isolate the problem.

    it’s a shame they introduced Emoji support in the first place in my opinion

    I suppose you also think it’s a shame they introduced support for native Chinese, Japanese, and Korean characters, since that’s why the support was added in the first place.

    but even if they don’t come up with a fix for it

    A fix for what again? I have several sites without this problem, and you refuse to do any troubleshooting to narrow down what your problem was.

    disabling Emoji support is no bad thing – it slows down page loading times among other things.

    Incorrect: http://peterwilson.cc/intuition-is-crap/

    I found your comments to be premature.

    I find your rush to disable a core feature without troubleshooting to be premature.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Please do not put code like that into your theme’s functions.php file. It has nothing to do with your theme.

    This plugin has the exact same code if you want to use it:
    https://wordpress.org/plugins/disable-emojis/

    Plugins are better than copy/pasta because plugins can be updated, disabled, etc. Same code, same effect, better management.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    salromano, if you’re satisfied with the solution, that’s great!

    If you’d like to maintain the expanded character support and find a better solution, we’d be happy to work with you.

    James Huff, I’m not sure what you mean by this:

    It’s not a bug, the editor shouldn’t be operating slowly

    The fact that the editor is operating slowly is, surely, a bug. No? Not just for me but for others too.

    What else can we do to “troubleshoot to isolate the problem”?

    I would be quite willing to help, but as far as troubleshooting goes, I’ve disabled Emoji – sorry – “support for native Chinese, Japanese, and Korean characters” and the bug – yes, bug – has now gone away.

    Samuel Wood, I never suggested it was anything to do with my or salromano’s theme.

    The functions.php file doesn’t just affect theme issues, it is a way of disabling this new facility which has caused the text editor to be too slow to be used. It was a trade-off which was worth it because out blogs were unworkable without it.

    And although it may not have sorted the issue, it has allowed the text editor to work again.

    Oh, and this new functionality does add extra load – unnecessary load in many cases – with the extra scripts.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    The fact that the editor is operating slowly is, surely, a bug. No? Not just for me but for others too.

    If it can be reliably reproduced in core without any plugins active and only the default theme active, then it’s bug. You refuse to do that, so right now it’s just a problem with your site as far as we’re concerned. I know there are two reports in this threads, and a Stackoverflow thread you linked to, but WordPress 4.2 has also been downloaded over 5 million times, so consider that before coming to the conclusion that this is actually a bug in WordPress: https://wordpress.org/download/counter/

    What else can we do to “troubleshoot to isolate the problem”?

    I already posted it. Again, try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Fifteen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    I’ve disabled Emoji – sorry – “support for native Chinese, Japanese, and Korean characters” and the bug – yes, bug – has now gone away.

    See, you’ve nuked a core feature that went through months of developer and community testing to solve your problem. That doesn’t seem quite right, does it? 😉

    The functions.php file doesn’t just affect theme issues, it is a way of disabling this new facility which has caused the text editor to be too slow to be used.

    Plugins are safer, easier, can be used with all themes, and approved by the core or plugin teams. A plugin solution is always better than a functions.php hack, and one has been available for days: https://wordpress.org/plugins/disable-emojis/

    Oh, and this new functionality does add extra load – unnecessary load in many cases – with the extra scripts.

    From a certain point of view: http://peterwilson.cc/intuition-is-crap/

    Well, thank you James. I have done what you have suggested – deleted this workaround code from my functions.php

    …I have then disabled all plugins…

    ..then I deleted everything else in my functions.php that may have affected the issue (including javascript calls)…

    …then I removed everything I had added to my site’s .htaccess other than the WP standard code…

    …and several permutations of the above steps, and the latency in text editor mode still remained.

    However, every time I tested this (after hard refreshing in Chrome developer mode) the (unpublished) blog article I was testing it on was in a pretty long post I had been drafting – over 2,600 words.

    I don’t know why, but I thought I would test editing a shorter blog post I had published some time ago – one with only 380 words – and, would you believe, it did not have this problem.

    So I went through various old posts, and this is what I found:

    Post which had 3,673 words – problem persisted

    Post which had 4,491 words – problem persisted

    Post which had 639 words – no problem

    Post which has 932 words – problem persisted

    Post which has 264 words – no problem

    So, this is somewhat scientific but in some ways not, but there seems to me to be a link between the amount of words in a post and this latency in the text editor.

    Please be aware that I always, without fail, compose my posts in text mode, and not everybody does. Not everybody writes long articles either, so it may be more widespread than people realise.

    To be sure, I have also switched to visual editor mode in long articles and short ones and have never experienced the latency.

    I have also installed and activated the latest version of TwentyFifteen and the problem persisted.

    So, from my investigation, I can conclude: I am experiencing severe latency in text editor mode (and text editor mode only, not visual mode) which only affects longer articles, and this problem only manifested itself after WordPress introduced emoji/Asian character support, and goes away if emoji is disabled via plugin.

    Now that sounds like a bug to me, but I am prepared to accept that it isn’t! Please could you give me your thoughts?

    Oh, and I will install the plugin and not keep that code in my functions.php file, if it will make you happy! 🙂

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Interesting, I just tried now with 2,000 characters, then 4,000, and I had no issue.

    I wonder if there’s maybe a character or media embed in there causing the slowdown.

    Try with just 2,000 characters of plain text from http://lipsum.com/ (use the “Bytes” option).

    I forgot to include in my post, but edited it just before you responded, that I tried testing it on TwentyFifteen and the problem still persisted.

    I have done what you suggest, and used Lipsum text, and cannot replicate the problem in either TwentyFifteen or my own theme.

    I tried up to 16,000 (yes, sixteen thousand) words of Lipsum and cannot replicate the problem.

    Yet as soon as I pasted the 2,665 words of my draft post onto the end of those 16,000 LipSum words, the problem arose – without me even having to ‘save draft’ and refresh the page.

    Then I re-deleted that draft post text I had pasted, and the problem went away – again, without having to press ‘save draft’.

    I think we’re getting closer to identifying the problem, but I’ll be darned if I can work it out myself!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    So, it’s in your Draft text somewhere. 🙂

    Would you please provide it via the pastebin?

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Text editor extremely slow’ is closed to new replies.