Support » Fixing WordPress » Text Edit automatically switches back to Visual Editor

  • Ok, so I know this has been an issue but I’m running into some problems with it recently. In order to embed a video from my CDN I need to insert specific code onto a page, using text editor. However, when I hit publish, WordPress automatically switches the page back to visual editor, which then alters the code I just inserted and the video does not appear.

    I understand that I can simply disable visual editor and function only using text editor through my user settings. However, I need then to switch back to visual editor so that I can directly input and edit meta information for SEO purposes. As such, I have to keep several tabs open to input my meta info, publish it, then deactivate visual editor, to then publish my video, and then bring it all back to normal.

    Is there any way to keep the post / page editor version on text edit when I hit publish or update the page?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I understand that I can simply disable visual editor and function only using text editor through my user settings.

    can i ask how you do this?

    If you go into your user profile settings, at the very top of the page is a radio check box that says “disable the visual editor when writing.” Check that box and click save, then the visual editor is no longer available.

    Thanks for the tip,

    about your problem, did you try with the default theme? and/or disable your plugins? and/or with a clear browser cache ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Text Edit automatically switches back to Visual Editor’ is closed to new replies.