Support » Plugin: Search in Place » Text disappears on page by searching

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author codepeople

    (@codepeople)

    Hello @ankernet

    I’ve tested your page in English and it is working fine for me, please, watch the video by visiting the following link:

    https://wordpress.dwbooster.com/customdownloads/2021/03/20/video-o.mp4

    However, pay attention to the areas and translations. As you can see in the video there are joined words without separation between them.

    Also, in the plugin configuration page, you enter the selector of the areas where the plugin should search (through the attribute: “Search in page selectors”). If there are terms in areas whose selector was not included in the list, our plugin will ignore them in the search results.

    Best regards.

    Thread Starter ankernet

    (@ankernet)

    Thank you very much for you answer.

    There are two important things I dont understand. First is, the words without separation appear only while searching. In the text and also in the translation they are all correctly separated, I checked it again. Why do they lose the separation while searching?

    Second one is, as I can also see in your video for example at 0:11 that text passages disappear completely. “Troughout its history,…” – then the following text got missing while searching.

    Thanks in advance

    Plugin Author codepeople

    (@codepeople)

    Hello @ankernet

    Please, try the following modification:

    * Go to the settings page of the plugin, and remove the “body” option from the “Search in page selectors” attribute.

    Best regards.

    Plugin Author codepeople

    (@codepeople)

    Hello @ankernet

    I’ve continued analyzing your case, and I see your website is loading the “trp-translate-dom-changes.js” script that is usually used to translate the texts on the page in real-time. So, I guess this script is trying to translate the texts again once our plugin highlights the terms, and this dynamic translation causes the loss of the texts.

    Could you disable the dynamic translation and test the search in place again, please?

    Best regards.

    Thread Starter ankernet

    (@ankernet)

    Hello codepeople,

    I removed the body option. But I guess this doesnt make a change.

    But your second advice was very helpful, I think. I disabled the dynamic translation in advanced options of tranlatepress and tested once again, and it looks like its working correctly now. I have to test in some browsers and mobile version, but looks good till now 🙂

    Kind regards,
    Jasmin

    Plugin Author codepeople

    (@codepeople)

    Excellent !!!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.