Support » Fixing WordPress » Text and content doesn’t show up in post after publishing

  • Resolved hanenwurger


    We’re having this really odd problem here with WordPress.

    We have this (quite long) post that appears fine in the editor, but once it’s published (or previewed), absolutely nothing appears in the post itself, except for the title, the author and the tags. You can find the post here.

    It’s a chart of alternative music with 1942 bands, so it’s quite extended. My gut feeling says that the cause of this problem is the length of the post.

    BUT, however, it used to work fine! It must have happened since the upgrade to WP 2.5, because the post just appeared fine in the past.

    Does anyone have an idea of what’s going on here? It would be greatly appreciated.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Thread Starter hanenwurger


    I’ve found out that this must have something to do with the length of the post.

    Is there a maximum length implemented in WP 2.5, which wasn’t there in previous WP-versions?

    Thread Starter hanenwurger


    Question: can this be caused by unusual characters since the update?

    The problem is likely that you are pasting code (such as a table, php, javascript, etc.) into the post editor. Look for a plugin that lets you use this code directly in your posts.

    Thread Starter hanenwurger


    Thanks for the reply.

    Two questions however:

    1) Why didn’t this happen in earlier versions of WP?

    2) The author of this post never used tables, php, javascript or anything else whatsoever.

    I’ve divided the post over four posts now. That seems to work, so I’m still convinced that it has something to do with the post’s former length.

    Nonetheless, thanks for your advice.

    I am having the same problem. I entered a new, very long post, with *no php code of any kind*. The post was within my PHP settings’ max POST size for submitted form content. The data saved to the database without a problem, but when the post is viewed in full on the website proper, the content is blank.

    This has never occurred prior to the latest releases of WordPress.

    I don’t see anything in (the user-unfriendly) trac about this.

    Looks to be working fine for me! Both in FF3 and IE7.

    Edit: Just realised this is an old post, but was never resolved.

    Thread Starter hanenwurger


    Exactly, I’ve divided the long post in four different sections as a workaround.

    Look, it must be something small that we just can’t figure out. Can someone shine the PHP-techie beam against the nightsky of Gotham city?

    You need to validate and fix your code (the first step in troubleshooting display problems).

    I would be happy for you to send all of the code of the post to me, and I will test it on my WordPress. Please find my email address at

    Thread Starter hanenwurger


    With all the respect, Iridiax – ànd you’re right about that – but I don’t think it’s valid code-related this time.

    All I did was dividing the post over four different posts, which should result in the same error in one of the posts somehow. So I don’t think it has anything to do with that.

    It could be the reason, but I strongly doubt it.

    I can confirm that the problem with long entries has nothing to do “invalid” xhtml. WP is simply not pulling from the database any text at all if the entry is a certain size or larger. It is writing to the database fine when the entry is posted/saved. The same entry, split into three parts, is visible on the live site without any problem (each part, separately). Recombine the parts, and the entry is not pulled from the database.

    Has anyone found resolution to this problem, because I am having same problem when I upgraded from 2.0 to 2.5. Some of my old posts don’t show up, but if I truncate them in the database they do show up. I am not sure if this is strictly length related because some of my posts with similar length or slightly higher do show up. I would appreciate if someone can point how to fix this.

    I fixed the problem by commenting
    //add_filter(‘the_content’, ‘wpautop’);
    in “wp-includes/default-filters.php” file

    I don’t know why but I can see my post now.

    Thread Starter hanenwurger


    Thanks for that Shahbhat!

    You can also do this on a per-post basis by installing a plugin like Exec PHP and then adding this line of code to the top of the page or post you’re having issues with:

    <?php remove_filter('the_content', 'wpautop'); ?>

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Text and content doesn’t show up in post after publishing’ is closed to new replies.