Support » Plugin: CMP - Coming Soon & Maintenance Plugin by NiteoThemes » Text after submitting to mailinglist doesn’t appear

  • Resolved vlooon

    (@vlooon)


    Hi there,
    Thanks for your nice and handy plugin!
    But… after clicking the submit button (‘Inschrijven’), no text appears, so the user doesn’t know if the subscription was successful or not. I see in the demo that it is supposed to work. It has nothting to do with my custom css (I checked this). Subscription does work behind the scenes (I see the email addresses in the list in the back-end). What else can be the problem?
    Thanks!
    Daphne

    • This topic was modified 3 months, 2 weeks ago by  vlooon.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author NiteoThemes

    (@niteo)

    Howdy @vlooon, the submit request is beeing blocked due to incorectly set your domain in WordPress.

    From console:

    Access to XMLHttpRequest at 'http://haptonomie-rotterdam.nl/wp-admin/admin-ajax.php' from origin 'http://www.haptonomie-rotterdam.nl' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

    which means, if you accesss your website via http://haptonomie-rotterdam.nl/ or https://haptonomie-rotterdam.nl/ without www subscribe function works as expected.

    But if you access your website via http://www.haptonomie-rotterdam.nl then the submit request goes to http://haptonomie-rotterdam.nl/wp-admin/admin-ajax.php and it is blocked.

    Maybe if you go to Settings > General in your WordPress and change the WordPress Address (URL) to include www it will help..otherwise I am not sure.

    Or simply use free MailChimp account to catch your subscribers which should work as well 🙂

    Alex

    Hi Alex,

    I feel a little bit stupid :S, but I changed the URL’s and it’s fixed.
    Many many thanks!

    Greetings,

    Daphne

    Plugin Author NiteoThemes

    (@niteo)

    Hi Daphne, no worries – those are the little things!

    Glad it works now, Alex

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.