Support » Plugin: WP Mail SMTP by WPForms » Tests of SMTP Hang on Blank Screen

  • Resolved peaksmedia

    (@peaksmedia)


    I have seen another post on this forum with the same issue but I’m not sure where to look for the suggested resolution:

    https://wordpress.org/support/topic/test-email-hangs-blank-screen/

    When I run a test I do not get an output on screen of true or false the screen is just blank.

    The thread noted above suggests the port is being blocked. But by who? My host is SiteGround and the emails are running through Office 365. So which one would be blocking the port?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • peaksmedia

    (@peaksmedia)

    Update this may have been caused by default SiteGround MX records not being removed. Waiting for propagation to confirm if removing the settings fixes the issue.

    peaksmedia

    (@peaksmedia)

    OK I have made changes to MX records – no luck still hangs/goes to blank page when testing.

    Plugin Author Slava Abakumov

    (@slaffik)

    Hanging can mean a lot of things.
    I have faced with this problem when SMTP configuration was incorrect. The server tried to connect to SMTP for too long and was bumped by a PHP time execution limit.
    The blank screen almost always generates a record in PHP error log that will help to debug.
    So please check your error log (it’s available from a CPanel as well) and post here the message. But I’m pretty sure it will be the timeout error.
    In this case, you will need to double check your settings: correct port AND encryption (different ports work with different encryption).

    peaksmedia

    (@peaksmedia)

    Thanks yes it is a timeout error.

    Will have to check with the IT guy who gave me the credentials for the SMTP settings. Sound like they are not correct.

    I’ve tried different ports and encryption settings but no luck. Same issue 🙁

    peaksmedia

    (@peaksmedia)

    Thanks Slava – I have checked with the IT person and they assure me the settings they have provided are correct.
    (please note I replaced the IP address with xxxxx)

    [Tue Dec 05 07:46:07.890551 2017] [:warn] [pid 23127] [client xxxxx] Timeout waiting for output from CGI script /home/cairnska/public_html/wp-admin/options-general.php, referer: https://cairnskarthire.com.au/wp-admin/options-general.php?page=wp-mail-smtp%2Fwp_mail_smtp.php

    In the past when I have had incorrect password the test comes back as “false” it doesn’t just go to a blank page.

    peaksmedia

    (@peaksmedia)

    IT guy is saying: “…. from what I have read, WP Mail may not support STARTTLS protocol”

    Is this correct?

    I am trying to connect to Office365

    Server name: smtp.office365.com
    Port: 587
    Encryption method: STARTTLS
    (I have “Use SSL encryption” selected).

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Tests of SMTP Hang on Blank Screen’ is closed to new replies.