WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Testimonials Stacking on first load

[Resolved] Testimonials Stacking on first load

  • I’m seeing the same problem mentioned in this resolved thread
    http://wordpress.org/support/topic/testimonials-stacking-on-first-load

    Problem occurs in both safari on my mac, and in Chrome on a PC and on a chrome book as well.

    -Cleared cache on server
    -cleared cache on cloudflare
    -turned cloudflare off
    -cleared cache on browsers

    None of these resolved the problem.

    Tried resetting the settings in the reset tab of testimonials plugin, no luck.

    I’m using the following shortcode to run the testimonial at the top of a home page.

    <div style="text-align: center;">[testimonialswidget_widget category=testimonials order=asc height=300]</div>

    http://www.courvo.biz/

    When I uncheck the box for “Pre 2.15.0, Testimonials’ used custom JavaScript for transitions. use_bxslider”

    It works better, but then the formatting of the testimonials breaks….

    What can I try next? (been through the support forums on Aihrus as well, didn’t see anything on this topic.)

    https://wordpress.org/plugins/testimonials-widget/

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Michael Cannon

    @comprock

    Try resetting your testimonials settings and widget options. Then see how it goes.

    I’m sorry. I did that already.

    Tried resetting the settings in the reset tab of testimonials plugin, no luck.

    set them all to display:none by default.

    sometimes people use the .hide() jQuery, which happens later on in the page-load than a css property of display:none would.

    Build your own with this? http://trendmedia.com/news/infinite-rotating-images-using-jquery-javascript/

    and a custom post type of ‘testimonials’?

    Plugin Author Michael Cannon

    @comprock

    Can you change your theme to TwentyTwelve or the like quickly and see if it’s a theme styling conflict?

    This might help prevent the page bounce:

    .testimonials-widget-testimonials {
    height: 117px;
    overflow: hidden;
    }

    The slow load is partly due to the huge scripts loaded in the 2nd iframe for vimeo. I wonder if that iframe could be loaded after document.ready?
    http://stackoverflow.com/questions/6805297/using-jquery-to-dynamically-load-vimeo-videos

    Plugin Author Michael Cannon

    @comprock

    Any luck with the theme change for helping debug?

    Also, would you mind trying out this RC https://github.com/michael-cannon/testimonials-widget/archive/2.18.1RC4.zip?

    I just tried 2014 on a copy of the site at http://courvo.staging.wpengine.com

    I still see the stacking issue.

    going to try the css above and try the RC from above (thanks for that!)

    Quick note, the css change does hide the stacking issue a bit.

    I just added it on the wordpress 2014 theme on the staging site above (still running at the moment)

    In this case I still see 2 quotes stacked, but not all 10. I could probably reduce the height a bit more to bring that down to a single quote Or just two text lines.

    I’m going to try the rc next….

    While I would like things to be as clean and perfect as possible, the css work around was a good idea and something I can run with if we don’t find something better.

    After commenting out the CSS workaround, here are

    The next two things I tried

    1.) I installed 2.18.1RC4 and experienced the same thing. Still have stacking issues going on same as before

    2.) with 2.18.1RC4 running, I then tried deleting/removing the Vimeo video, just in case that had some impact. The test site is currently running without the Vimeo video and with 2.18.1rc4 still running.

    Unfortunately the stacking issue is still there.

    Findings So far

    – I guess this rules out the Focus Pro theme on Genesis framework from StudioPress

    – The CSS work around is better than nothing. I further tested this in several (not exhaustive) mobile situations and works well there too.
    The new RC didn’t solve the problem.

    With this running on the Staging area of WPEngine it demonstrates that Cloudflare, which runs on the live site at courvo.biz but not staging, has no impact. So the cache there(cloudflare) is not the culprit, nor is the js nor css minify options.

    WPEngine does not run a cache on their staging sites, so their built in cache is not responsible (btw before I created this thread hear, I had created a ticket with wpengine first, and confirmed that caching was not an issue, this just reconfirms it)

    Did you try ajmcfadyen’s suggestion?

    I built an Ajax image slider once that loaded only the first image, then continued to load the rest of the stack after the page is fully rendered. Does that sound like a viable option here?

    @chris Dillon I missed @ajmcfadyen ‘s suggestion earlier. I haven’t tried it yet.

    At the moment, I’d like to keep everything limited to the plugins that I’m running with out adding more.

    That may or may not be possible if the error persists and I have to search for alternate solutions. I have used other testimonial plugins and many other slider scenarios too.

    For client reasons and for the end result, I didn’t want this to get too complicated such that it can be easily managed later…. I may revisit it, if nothing better works out. 🙂

    Plugin Author Michael Cannon

    @comprock

    Brettbum,

    Argh… I’m sorry for the troubles. I’m checking this out again on a clean installation.

    You sure you’re using bxSlider and can confirm that bxSlider specific JavaScript being called in the webpage footer?

    When testing, were any other plugins or such activated?

    Plugin Author Michael Cannon

    @comprock

    Oh yeah, height doesn’t work with bxSlider option as bxSlider automatically sets the height to the tallest and slides within that size.

    Plugin Author Michael Cannon

    @comprock

    Okay, I’ve just done a clean install on WP 3.9-alpha using RC4 I suggested above and the simple [testimonialswidget_widget] on a page with TwentyFourteen.

    The page and testimonials loads up quick and without any stacking whatsoever.

    If you can get me access to a dev system to look, I might be able to help debug further.

    Email access to support@aihr.us.

    – bxslider is running, you can see it load for example by running the site through pingdom tools

    http://tools.pingdom.com/fpt/#!/enh5bS/http://courvo.staging.wpengine.com/

    That raised a question for me, though. It looks like the Testimonials Plugin is calling two different versions? (is that normal?)

    both of these load

    This one first
    http://courvo.staging.wpengine.com/wp-content/plugins/testimonials-widget-2.18-2.1RC4/assets/css/jquery.bxslider.css?ver=3.8.1

    Then several other files later this one

    http://courvo.staging.wpengine.com/wp-content/plugins/testimonials-widget-2.18-2.1RC4/assets/js/jquery.bxslider.js?ver=4.1.1

    —–

    Tonight, as opposed to when I opened this ticket, the stacking does seem to disappear faster. That may or may not be something to do with the RC? Thought I’d mention it.


    Separately, I’ve tried turning off all plugins and turning them on one at a time. (with both the focus pro theme from studiopress and with 2014)

    The only plugin that seems to potentially impact things is

    http://wordpress.org/plugins/easy-fancybox/

    Easy Fancy box

    It’s very difficult to tell if this combo (Testimonials + Easy Fancybox) is the problem.

    Any chance you could try it on one of your own sites/tests sites or servers?

    sometimes plugin conflicts are obvious, in this case I just can’t quite tell yet.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] Testimonials Stacking on first load’ is closed to new replies.