WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Testimonials Not Shown From Beginning

[Resolved] Testimonials Not Shown From Beginning

  • Hi,

    I have over 120 testimonials and growing, so am using the code [full-testimonials category=”xx”] to show them all and auto-paginate. It currently creates six pages (about 20 per page – I don’t know why 20).

    My problem is that when viewers arrive at the page, they don’t see the first page of testimonials (ie the newest ones). It seems to land on the 2nd page.

    Can anyone think of any reason why that would be so??

    Ta

    J

    http://wordpress.org/plugins/gc-testimonials/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author devnz

    @eringarscadden

    Hi,

    Do you have other plugins running on the site? Sounds like some sort of conflict going on…

    Can you give me the address of the site so I can take a quick look?

    Hi Devnz,

    As well as GC Testimonials, my site ( http://www.oakleyit.co.uk ) also uses these plugins (all updated to their latest versions):

    -Aksimet (by Automattic)
    -All In One SEO Pack (by Michael Torbert)
    -BackUpWordPress (by Human Made Limited)
    -Contact Form 7 (by Takayuki Miyoshi)
    -Custom Post Type Maker (by Jorn Bakhuys)
    -Google Analytics for WordPress (by Joost de Valk)
    -Google XLM Sitemaps (by Arne Brachhold)
    -jQuery Lightbox (by Perdo Lamas)
    -MaxButtons (by Max Foundry)
    -WordPress Importer (by wordpressdotorg)
    -WordPrss Reset (by Matt Martz)

    The site was developed by a professional web developer so I have no idea what some of these plugins are.

    Thank you for offering to take a look; very kind.

    J

    PS – please take note (and accept my apologies for slowing you down) that the site is new and opens extremely slowly and we can’t seem to fathom why that is the case.

    All plugins are updated to the latest verions, we know it isn’t a DNS problem (we’ve checked “@” and “www” Records) nor a hosting problem server (it is Shared Hosting but my old non-WordPress site ran fine and apparently all other sites are running perfectly).

    J :/

    PPS – URGENT CORRECTION !!

    I’m so sorry for wasting your time devnz (and anyone else looking) but my new site (www.oakleyit.co.uk) uses the shortcode [single-testimonial id=”xx”] to display single testimonials, which I add to new manually created pages.

    So, a copy of the site is on http://planetvideo.co.uk/, where I’m testing [full-testimonials category=”xx”] with auto-pagination, and where you can see how it takes you straight to the 2nd page.

    When I’ve worked out how to make it display things correctly, I’ll make the change to http://www.oakleyit.co.uk.

    I really hope this makes sense and apologise once again for the earlier mistake.

    J :'(

    Plugin Author devnz

    @eringarscadden

    Looking on http://planetvideo.co.uk, I can see in the footer that the script for the pagination is setting the currentPage element to 2, so it is loading the second page by default. This needs to be set to 1 so the first page loads by default.

    In testimonials.php, at around line 68, change the line to look like this:

    $output .= '$("#testimonials_container").quickPager({ pageSize: 20, currentPage: 1, pagerLocation: "after" });';

    It looks like the developer has set the script to show 20 per page here as well. The main thing is the “currentPage: 1” is changed from “currentPage: 2”.

    Hope that helps.

    Jan Rymarz

    @jan-rymarz

    It totally solved my the problem and I’ve learned something new so thank you.

    In fact, I’ve thought of a GREAT possibility of combining [full-testimonials category=”xx”] with categories and pagination … but I think I should start a separate question this one is answered and closed.

    So, thank you again devnz and maybe speak again in the next thread 🙂

    J

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Testimonials Not Shown From Beginning’ is closed to new replies.