Support » Plugin: Testimonials by WooThemes » Testimonial fields not being recognized?

  • Resolved Amber


    I’m using GF with Testimonials by WooThemes to create a user submission for testimonials; since there’s not one included out of box. I have been able to successfully map GF to the Testimonials custom post type but not it’s fields.

    I’ve been on Gravity Forms support checking similar posts and have read that it could be because the fields are stored in an array (not sure), they also mentioned that posts (testimonials) need to be created with the post meta fields filled out before GF would recognize the field as “existing”. I did create/publish several test testimonials with all the Testimonials fields filled out but GF still doesn’t not recognize them as existing. Testimonials uses the following fields:

    gravatar_email, byline, url

    I even tried using GF to “create” a new field based on testimonials field names hoping it would work but it does not. Again, since these fields are all stored in an array I’m not sure if that might be the problem in why they are not showing up?

    Could anyone provide me with any pointers in the right direction?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Resolved:

    This can be accomplished via Gravity Forms by using “Custom Field” and “New Custom Field Name”.

    The keys that need to be entered are _gravatar_email, _byline and _url (as shown when checking the DB for reference) and not just gravatar_email, byline, and url.

    Hi, I had the same exact problem.
    I was going to dig into the code and the db, when I stumbled upon this thread, so it seems worth to try asking.

    Your solution doesn’t seem to work for me.
    Not as-is, at least.

    Maybe it’s a dumb question, but are the custom fields EXACTLY as reported?
    I created 5 inputs, 3 of them are the custom fields, namely:

    Your Name
    Title, set as cpt Testimonial

    Your testimonial

    Job, position
    Custom field: “_byline”

    Custom field: “_url”

    Your email
    Custom field: “_gravatar_email”

    After submission, a new testimonial is correctly created, but the custom fields are not.
    Any suggestion?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Testimonial fields not being recognized?’ is closed to new replies.