Support » Plugin: Postman SMTP Mailer/Email Log » Test failed but message is sent

  • Resolved Marco Moreira

    (@marcomoreirasp)


    Hello,

    The plugin was working OK but it suddenly stopped.
    Now, I’m having the exactly same problem with the MemberPress topic:
    the test message returns “failed” but is sent.

    The reason why I’m posting as new topic is: I’m not using MemberPress.
    I tried to deactivate every plugin and theme (tested with Fourteen). But still got “failed”.

    The problem affects the website forms. I’m using Ninja Forms, with “Send with Ajax” option. When clicked on “Send” button, it keeps “Processing…” and no success or failed message appears. Just freezes.
    If I deactivate the Ninja Forms and go to the Postman’s send messsage test, I still get “failed”.

    Here’s the diagnostic test:

    OS: Linux server.idclinux.net 3.14.32-xxxx-grs-ipv6-64 #1 SMP Tue Jun 30 18:50:21 CEST 2015 x86_64
    HTTP User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:40.0) Gecko/20100101 Firefox/40.0
    Platform: PHP Linux 5.6.13 / WordPress 4.3.1 pt_BR
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=No, mcrypt=Yes
    WordPress Theme: Vulcano
    WordPress Plugins: Debug, Favicon by RealFaviconGenerator, Google Analytics Dashboard for WP, Ninja Forms, Postman SMTP, Compress JPEG & PNG images, Two Factor Authentication, UpdraftPlus – Backup/Restore, Wordfence Security, Yoast SEO
    Postman Version: 1.6.23
    Postman Sender Domain (Envelope|Message): marcomoreira.com.br|marcomoreira.com.br
    Postman Prevent Message Sender Override (Email|Name): Yes|Yes
    Postman Transport URI: gmail_api:https:oauth2://www.googleapis.com:443
    Postman Transport Status (Configured|Ready|Connected): Yes|Yes|Yes
    Postman Deliveries (Success|Fail): 1852|477
    Postman Bind (Success|Fail|Path): Yes|No|[…]/wp-content/plugins/postman-smtp/Postman/PostmanWpMailBinder.php
    Postman TCP Timeout (Connection|Read): 10|60
    Postman Email Log (Enabled|Limit|Transcript Size): Yes|10|128
    Postman Run Mode: production
    Postman PHP LogLevel: 10000
    Postman Stealth Mode: No
    Postman File Locking (Enabled|Temp Dir): Yes|/tmp

    https://wordpress.org/plugins/postman-smtp/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    What does the email log say for the reason of failure?

    It says ‘Sent’…

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    I think you’re not telling me something, it can’t be both Failed and Sent.

    Postman Deliveries (Success|Fail): 1852|477

    Have you really sent 1852 emails? You’re not running WooCommerce, this number seems really high to me. Plus you have 477 failed emails, also unusually high.

    My guess is that you have spam malware on your site, and Google is rejecting your email periodically because it thinks you’re a spammer. This can happen if pirated software is installed on the site. Or you might have hit Google’s sending limits.

    Look through a few entries in your Email Log. Do you recognize each email attempt? The clue will be in the log.

    This number is because the login page was attacked last week. So Wordfence sent alert emails, telling me that some IPs were blocked.
    Besides that, I installed the Two Factor Authentication plugin.

    I don’t have all the log anymore. I tried to solve this problem reinstalling the plugin, deleting the plugin settings, etc…

    If you want to test, just go to my site. The contact is on the footer.
    When you click “ENVIAR” (SEND), the button turns to “ENVIANDO” (PROCESSING) and freezes.
    On the Postman page, the test returns failed. But on the log, the status is “SENT”. It sounds like the ajax is not returning true or false…?

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    If the log says Sent, the email is sent. What makes you think it’s not? Are you not receiving the email?

    As for Ninja Forms, yes, it sounds like the Ajax is not returning. This could either by a Javascript conflict or Server Side conflict. Have you installed or upgraded any plugins? I see you have Debug. Check the Debug log to see if there are any NOTICE or WARNING messages in the log when you submit a Ninja Form. That will mangle the Ajax response.

    As for Postman Test Message failed, you have to post more information. Is there no error message from the Google server? Can you post the Transcript that appears on the following step after Test Message Failed.

    Yeah, I’m receiving the email…
    I’m just telling that Postman sends the email (and logs as SENT) but returns FAILED.
    The “Session Transcript” is locked. The Status box (“Send the message”) is blank and when I click on the “Session Transcript”, nothing happens, just “Send the message” step turns red.

    I changed to SMTP settings yesterday. I created a user on my cpanel just for the Postman. But it was returning failed too and “freezing” the form (no success or failed message). So, turned it back to Gmail.

    It installed the WP Mail too. The feedback’s message on form turned to be ok (for success or failed), but the message’s not sent. It was just for testing purpose, because I really like the features that Postman gives me (like Gmail)…

    I installed the Debug plugin but it sounds like it’s not generating the log. There’s no debug.log on the FTP. Filezilla searched all folders and didn’t find. I’m trying to see if I need to put something on PHP.ini…

    Just now I logoff from admin and then tried to log in.
    It failed and showed some warnings. Never seen before. See below.
    When tried go log in again, then it was ok.

    Warning: ini_set() has been disabled for security reasons in […]/wp-content/plugins/postman-smtp/Postman/Postman-Mail/Zend-1.12.10/Validate/Hostname.php on line 1416

    Warning: ini_set() has been disabled for security reasons in […]/wp-content/plugins/postman-smtp/Postman/Postman-Mail/Zend-1.12.10/Validate/Hostname.php on line 1524

    Warning: ini_set() has been disabled for security reasons in […]/wp-content/plugins/postman-smtp/Postman/Postman-Mail/Zend-1.12.10/Validate/Hostname.php on line 1416

    Warning: ini_set() has been disabled for security reasons in […]/wp-content/plugins/postman-smtp/Postman/Postman-Mail/Zend-1.12.10/Validate/Hostname.php on line 1524

    Warning: ini_set() has been disabled for security reasons in […]/wp-content/plugins/postman-smtp/Postman/Postman-Mail/Zend-1.12.10/Validate/Hostname.php on line 1416

    Warning: ini_set() has been disabled for security reasons in […]/wp-content/plugins/postman-smtp/Postman/Postman-Mail/Zend-1.12.10/Validate/Hostname.php on line 1524

    Ok, I gave up for the moment.
    Unfortunately I’m not using Postman anymore.
    I installed another plugin that sends mail using SMTP/SSL connection and everything works fine now. Email test on admin is returning SUCCESS. And the contact form on website shows the feedback message.

    If you want to look further about the problem I’m having, I can active Postman again. Just ask anytime…

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Just now I logoff from admin and then tried to log in. It failed and showed some warnings.

    This may be the Debug plugin? If you disable the Debug plugin setting Enable Display Errors at on all website, these should be hidden.

    I installed the Debug plugin but it sounds like it’s not generating the log.

    It should be in wp-content/debug.log. You can also go to the Debug menu to view it in the WP Admin, Debug > Error Log

    I suspect that it is these very warnings you posted that is causing both the Ninja Forms to fail, as well as the Postman Send Test Message. They both use Ajax. I don’t know why it worked before and not now. Possibly your web host changed your PHP settings to prevent use of ini_set?

    Warning: ini_set() has been disabled for security reasons in [...]/wp-content/plugins/postman-smtp/Postman/Postman-Mail/Zend-1.12.10/Validate/Hostname.php on line 1416
    
    Warning: ini_set() has been disabled for security reasons in [...]/wp-content/plugins/postman-smtp/Postman/Postman-Mail/Zend-1.12.10/Validate/Hostname.php on line 1524

    Unfortunately I’m not using Postman anymore.

    I’m very sorry to hear that. I would be very grateful if you gave me an account on your site to investigate. You may contact me personally.

    Hello,

    This may be the Debug plugin? If you disable the Debug plugin setting Enable Display Errors at on all website, these should be hidden.

    Actually, the Debug was off at the moment.

    I really don’t know why but there wasn’t a debug.log on wp-content. On Debug > Error Log, it was empty. No Log. So I logged off and tried to log in but there was those warnings.
    Then, I installed Debug Bar… It displays some errors too. I tried to reinstall WP (from update at admin). No success. Then I tried another plugin to send the messages. Finally it was ok.

    Possibly your web host changed your PHP settings to prevent use of ini_set?

    Hmmm, maybe. But there’s a client that I’m developing a e-learning website based on WP. It’s in the same server of my website. And there Postman works without any errors with Ninja Forms. I turned Debug on (via wp-config.php) and there was some warnings about ini_set (load.php). Not the same as my website.
    It’s really strange… I think I’ll do a clean install of WP, the theme and plugins anyday.

    About the pirated software: I really don’t have. The plugins I’m using were installed directly from Plugins > Add New and I bought the theme from TeslaThemes.

    I will create a admin account for you today later.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    he plugins I’m using were installed directly from Plugins > Add New and I bought the theme from TeslaThemes.

    That’s the safest way.

    I will create a admin account for you today later.

    Cool! I figure it’s just a matter of hiding the warnings in the Zend_Mail library. If I can confirm it it’s an easy patch in the next release of Postman.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Hi Marco. I have a pre-release version that may address your issue. Are you able to get me an account on your system?

    Hello Jason…

    Totally forget to send your login user to test.
    I was in the middle of three projects… some days working 24h…
    Well, I updated the plugin with the latest version today and tested. The problem was solved!
    No ZEND errors anymore and the Ninja form is returning the feedback message as “succesful”.

    So, I went back to Postman…

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Great!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Test failed but message is sent’ is closed to new replies.