Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » Test email works, but not receiving notification emails

  • Resolved dassels

    (@dassels)


    Hi, I’m trying to figure out why we are not getting notification emails. I’ve tried all the things suggested in other posts but still not working. What I’ve tried:

    Setup WPmail SMTP. Sent test email and all working fine.
    Configured notifications in WP Form to use same email in “send to email” as configured in WPmail SMTP.
    Enable Debug in wp-config. No error messages that are related to WPforms shown.

    The form submits fine and I get the confirmation message but nothing shows up in our inbox but test emails from SMTP work just fine. No error messages in debug or anywhere else. Not sure what else is left to do, hoping someone will have some ideas.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Were you having issues with email notifications before you set up SMTP as well? If so, I’m having the same issue…switched to SMTP because it was a recommended fix and I’m still having the same issue with contact form submissions.
    My hosting site says they are getting no errors on their end.

    • This reply was modified 4 months, 3 weeks ago by rechor.
    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @dassels,

    When you get the chance, could you check if the ‘From Email’ in the form notification settings is the same as the ‘From Email in WP Mail SMTP?

    And in case it helps to share, the {admin_email} Smart Tag refers to the WordPress admin email, which can be found in your WordPress Settings > General

    Hi @rechor, if you’re still having issues with email delivery, could you try sending a test email from WP Mail SMTP, and share the results with us in a new thread when you get the chance? Thanks!

    Hi rechor, no it seems to be working on my end for everything else. All my notifications from woocommerce work fine when orders are made, it’s just the wpform that doesn’t seem to work.

    Hi Ethan, yes, I have already tried it with the email from WP mail SMTP in the “From Email section”.

    Currently I have it with the email only in “Sent to email” the same as SMTP because some servers can have issues with the email being in both. I also tried checking the box “force from email” and that didn’t work either.

    Attached are some screen shots of the current settings. As far as I can tell, it should be working.

    wpforms notifications settings
    SMTP email

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @dassels,

    Thanks for the details. Could you let me know the mailer option (e.g., Google, Sengrid, Other SMTP) you are currently using for WP Mail SMTP?

    Thanks!

    Hi,

    I’m using Other SMTP, and test emails with those settings work.

    The only weird thing, and dunno if somehow it’s connected, is that after I send the test email, the page refreshes and an old email appears (it was one used to first create the admin user account). Note that in settings -> general the current address for wordpress administration is the same one being used in WPforms and SMTP.

    As an experiment, I changed the admin user account email and now that email shows up as a ‘default’ in SMTP test email field.

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @dassels,

    Thanks for the details!

    The ‘Email Test’ tab in the WP Mail SMTP plugin automatically populates the field with the WordPress admin email. However it should not affect the email delivery of your site.

    For SMTP settings to be applied to the form notification email, you’ll need to set its ‘From Email’ to the same email address as the ‘From Email’ in WP Mail SMTP, or enable ‘Force From Email’ in WP Mail SMTP.

    If that does not resolve the issue, could you try using a different ‘Send To Email Address’ in the form notification settings?

    Please let me know how it goes.

    Thanks!

    Yep, already tried all that. Still nothing. It’s really weird.

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @dassels,

    Sorry to hear that! A possible reason for the issue could be due to our recent asynchronous email sending feature that may not be working well for sites with low traffic. We’re looking into the options for fixing this in a future update.

    In the meantime, could you try disabling that feature using the following custom code snippet:

    add_filter( 'wpforms_tasks_entry_emails_trigger_send_same_process', '__return_true' );
    

    In case it helps, here’s our tutorial with the most common ways to add custom code like this.

    For the most beginner-friendly option in that tutorial, I’d recommend using the Code Snippets plugin.

    When you get the chance to try that code snippet, please let me know how it goes.

    Thanks!

    I’m working with an organization that uses WPForms and recently started seeing heavily delayed notifications. Adding the code snippet above fixes it.

    However, the site is very busy (several page views per second), not low traffic.

    The problem happened regardless of whether it was using the built-in PHP mail() function of an SMTP server.

    As an editorial comment: I looked through all this async sending code trying to debug it, and it’s incredibly baroque and complex. I can’t believe how much impenetrable code there is to just eventually call (or not call) wp_mail(). I’d strongly encourage you to change it back to send email normally, without all of these layers of indirection — or at least make “send notification immediately” an option people can choose. Thanks!

    Plugin Support Ethan Choi

    (@ethanchoi)

    Hi @tigertech,

    Thanks for the feedback!

    Currently we’re looking into adding a built-in option to disable that code by default, and this should be released in a future update.

    Hope this helps 🙂

    In the meantime, could you try disabling that feature using the following custom code snippet:

    Yes, that did the trick! I’m seeing the notifications come through now. Thanks so much!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.