Support » Plugin: WP Mail SMTP by WPForms » Test email works, but Gravity Form Notification email does not

  • Resolved lplightle


    I am having trouble getting Gravity Forms Notification emails to be delivered. They don’t even go to spam. I installed WP Mail SMTP and configured it. The test email works great, but the Gravity Forms Notification emails are still not working. Here is the error from the Gravity Forms log file:
    2015-08-04 12:05:19 – DEBUG –> GFCommon::send_email(): Result from wp_mail():
    2015-08-04 12:05:19 – ERROR –> GFCommon::send_email(): The mail message was passed off to WordPress for processing, but WordPress was unable to send the message.
    2015-08-04 12:05:19 – DEBUG –> GFCommon::send_email(): The WordPress phpmailer_init hook has been detected, usually used by SMTP plugins, it can impact mail delivery.
    2015-08-04 12:05:19 – DEBUG –> GFCommon::send_email(): PHPMailer class returned an error message: SMTP Error: data not accepted.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,
    I ran into similar issues with WP-mail-SMTP for other plugins. I had to add the following filters to make sure the ‘FROM’ was correctly set. I have added these lines into my own plugin.
    Let me know if it helped for you.

    * Since the install of WP-Mail-SMTP we need to make sure the FROM is the same as the one specified in the plugin
    * These filters will overwrite any FROM send by other plugins.
    function custom_wp_mail_from($email) {
    	return get_option('mail_from');
    function custom_wp_mail_from_name($name) {
    	return get_option('mail_from_name');

    That worked! You are a miracle worker! Thank you so much for taking the time to help me.


    Hi Laura,
    No problem, we should all help each other, right ?
    Regards, Pascal.
    PS. Don’t forget to mark you request as ‘resolved’ at the bottom of this page somewhere.

    Hi casiepa, I have the same issue,

    where should I paste the code if im using wp-mail only


    As this plugin seems no longer to be updated, I switched to Postman SMTP ( That one solved all my remaining issues and the above code was no longer needed.

    I was still having this issue even after switching to Postman SMTP – what my solution was to remove the default from value, in the notification settings, {admin_email} and type in an email address.

    Hope this helps 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Test email works, but Gravity Form Notification email does not’ is closed to new replies.