WordPress.org

Forums

MyMail AmazonSES Integration
[resolved] Test Email - SMTP Error: Data not accepted. (4 posts)

  1. stemie
    Member
    Posted 1 year ago #

    I've configured the plugin and created a user and pass for SMTP within AWS. I've obviously installed MyMail Plugin also.

    When I attempt to send a test email, it gives me an error: "SMTP Error: Data not accepted. Check your settings"

    I've tried it a second time, making sure I'm copy pasting the correct smtp username and pass details into the 'Delivery Method: AmazonSES' section of MyMail plugin but the problem persists.

    Please advise what steps I can take to solve this problem?

    I've got email from AWS saying I have been granted production access to Amazon SES and I've verified my domain and setup DKIM.

    http://wordpress.org/plugins/mymail-amazon-ses-integration/

  2. stemie
    Member
    Posted 1 year ago #

    Problem solved, I had verified a domain but not the email address.
    Amazon Web Services is a bit of a maze.

  3. lorenzogiacomini
    Member
    Posted 1 year ago #

    I always get this error:

    Not able to use Amazon SES via SMTP cause of the blocked port 587! Please try a different connection, send without SMTP or choose a different delivery method!

    How can i solve it? Why Amazon port 587 should be blocked?
    Can I open a different port?

  4. revaxarts
    Member
    Plugin Author

    Posted 1 year ago #

    If you provider blocks certain ports you can't use them. Port 587 is required for Amazon SES so you can't use SMTP in this case. Please switch to the WEB api or ask your provider to open this port!

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • MyMail AmazonSES Integration
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.