Support » Plugin: Postman SMTP Mailer/Email Log » Test email keeps on failing

  • Resolved Abdul Basit Saeed

    (@abdulbasitsaeed)


    Hi, Jason.

    I just installed your plugin and configured it according to the video you have posted. Everything seems to work OK, but when I try to send a test email, the error I get is:

    Sending the message: Failed

    The plugin otherwise is sending out emails correctly.

    Could you please look into this? My installation info is:

    OS: Linux server93.web-hosting.com 2.6.32-531.17.1.lve1.2.58.el6.x86_64 #1 SMP Wed Jun 18 08:28:56 EDT 2014 x86_64
    HTTP User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
    Platform: PHP Linux 5.3.29 / WordPress 4.2.2 en_US
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=Yes
    WordPress Theme: News Pro Theme
    WordPress Plugins: Advanced Menu Widget, Akismet, BackWPup, BAW Login/Logout menu, Broken Link Checker, Contact Form 7, Email Obfuscate Shortcode, Export Users to CSV, Genesis eNews Extended, Genesis Simple Edits, Genesis Simple Hooks, Genesis Subpages as Secondary Menu, Genesis Tabs, Genesis Visual Hook Guide, Google Doc Embedder, Google XML Sitemaps, Jetpack by WordPress.com, MemberPress Business Edition, Menu Items Visibility Control, Multi Author Comment Notification, Postman SMTP, Simple Social Icons, Simple Staff List, TablePress, TinyMCE Advanced, Username Changer, Widget CSS Classes, Widget Logic, WordPress Access Control
    Postman Version: 1.6.23
    Postman Sender Domain (Envelope|Message): akuaana.org|akuaana.org
    Postman Prevent Message Sender Override (Email|Name): No|No
    Postman Transport URI: smtp:tls:oauth2://smtp.gmail.com:587
    Postman Transport Status (Configured|Ready|Connected): Yes|Yes|Yes
    Postman Deliveries (Success|Fail): 0|0
    Postman Bind (Success|Fail|Path): Yes|No|/home/akualum/public_html/wp-content/plugins/postman-smtp/Postman/PostmanWpMailBinder.php
    Postman TCP Timeout (Connection|Read): 10|60
    Postman Email Log (Enabled|Limit|Transcript Size): Yes|10|128
    Postman Run Mode: production
    Postman PHP LogLevel: 40000
    Postman Stealth Mode: No
    Postman File Locking (Enabled|Temp Dir): Yes|/tmp

    Best regards,

    https://wordpress.org/plugins/postman-smtp/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    Sounds like you have server-side errors. Install the Debug plugin, enable WP_DEBUG_LOG, and see if another plugin or theme is writing warnings or notices to the WordPress log when you submit the test email from Postman.

    I’ve installed Debug, and enabled WP_DEGUG_LOG as well. This is what the log file has:

    [06-Jul-2015 02:08:58 UTC] Array
    (
        [akismet_debug] => Array
            (
                [akismet_url] => https://241a19bd7d67.rest.akismet.com/1.1/deactivate
                [http_args] => Array
                    (
                        [body] => key=241a19bd7d67&blog=https%3A%2F%2Fakuaana.org
                        [headers] => Array
                            (
                                [Content-Type] => application/x-www-form-urlencoded; charset=UTF-8
                                [Host] => 241a19bd7d67.rest.akismet.com
                                [User-Agent] => WordPress/4.2.2 | Akismet/3.1.2
                            )
    
                        [httpversion] => 1.0
                        [timeout] => 15
                    )
    
                [response] => Array
                    (
                        [headers] => Array
                            (
                                [server] => nginx
                                [date] => Mon, 06 Jul 2015 02:08:57 GMT
                                [content-type] => text/plain; charset=utf-8
                                [content-length] => 11
                                [connection] => close
                                [x-akismet-server] => 10.4.64.75
                            )
    
                        [body] => deactivated
                        [response] => Array
                            (
                                [code] => 200
                                [message] => OK
                            )
    
                        [cookies] => Array
                            (
                            )
    
                        [filename] =>
                    )
    
            )
    
    )
    
    [06-Jul-2015 02:09:34 UTC] ERROR PostmanWpMailBinder: wp_mail is already bound, Postman can not use it
    [06-Jul-2015 02:13:43 UTC] PHP Notice:  get_theme_data is <strong>deprecated</strong> since version 3.4! Use wp_get_theme() instead. in /home/akualum/public_html/wp-includes/functions.php on line 3391

    I then proceeded by deactivating all plugins, after which the test mail was going out successfully. I narrowed it down to my membership plugin "MemberPress".

    However, upon activating MemberPress and Postman failing to send out a test email, no entry is made into the Debug log file.

    Please advise how to proceed further.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Well that’s odd. I’ll have to install MemberPress to see what it is doing to Postman. It might be writing something into Postman’s Ajax response, after the test mail is sent.

    But this isn’t preventing you from sending mail, correct?

    Emails seem to be going out correctly. It’s just the test email that keeps on failing.

    Thank you, Jason. I’ll wait for your response after some testing with MemberPress. 🙂

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Is there an entry in the email log for the test emails? Perhaps with a little more detail?

    That’s the weird part. Nothing shows up in the Postman Email log when I send out a test email and it fails.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    That is very strange. Would you enable Trace LogLevel in Postman’s advanced setting, send the test email with MemberPress activated and send me the entire log please: http://www.codingmonkey.ca/contact/

    Looks like MemberPress is paid only so I can’t get it.

    Just sent the log to you.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    And you definitely tried to submit a test email? I see you on the log page, and then I see you went back to the main menu, but there is nothing about a test email in the log. Somehow the other plugin ate the entire request!?? That’s some pretty badly written code :p I don’t know if I can help you. 🙁

    Yup, I definitely tried to submit a test email.

    Hi Jason,

    We have the same problem. The test email gets sent and delivered, but the test using your plugin fails. We too are using MemberPress. The author of MemberPress is freaking amazing and so is their plugin.

    I’ve reach out to him to see if you both could possibly find a solution.

    BTW, I’m really impressed with Postman SMTP. The instructional video on setting up credentials needs to be updated as Google never leaves well enough alone. I could still follow along, but you may want to update your video to match what we now see when setting up credentials.

    Keep up the good work and thanks for an awesome plugin.

    Jason, I’m Blair Williams the author of MemberPress. Feel free to contact me on our support form at https://www.memberpress.com/contact/ … I’d like to get this sorted and would be happy to get together to figure this out.

    Thanks! Blair

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Sounds good, Blair!

    Thanks!

    Looks like both plugins use wp_ajax_send_test_email. We’ll try and prefix the one in MemberPress for an upcoming release. You should probably do the same in your plugin as well @jason

    For anyone following this thread, the issue is “only” present when sending test emails, all other mail should function properly.

    Any MemberPress users affected by this can update to Edge build 1.2.5a2 for a fix. You may need to clear your browser cache and/or website caching after updating.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Test email keeps on failing’ is closed to new replies.