Support » Plugin: Postman SMTP Mailer/Email Log » Test email hangs

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    Please send your diagnostics info from the Tips and Diagnostics screen

    PHP Version: Linux 5.3.2-1
    PHP OpenSSL support: Yes
    PHP spl_autoload_register support: Yes
    PHP iconv support: Yes
    PHP error: (display_errors|errorReporting): |4983
    WordPress Version: 4.1.1
    WordPress Debug (WP_DEBUG|WP_DEBUG_LOG|WP_DEBUG_DISPLAY): ||1
    WordPress Active Plugins : Gravity Forms : Ultimate Addons for Visual Composer : Autoptimize : Church Theme Content : Envira Gallery – Albums Addon : Envira Gallery : Envira Gallery – Standalone Addon : The Events Calendar PRO : Forgiven Add-Ons : WPBakery Visual Composer : Postman SMTP : Revolution Slider : The Events Calendar : WordPress Importer
    Postman Version: 1.5.5
    Postman Sender: churchoffice@gmail.com
    Postman Transport URI: smtp:ssl:oauth2://********************************
    mtp.gmail.com:465
    Postman Transport Status (configured|ready|connected): Yes|Yes|Yes
    Postman Deliveries (Success|Fail): 0|1
    Postman Bind (success|failure): Yes|No
    Postman Available Transports : SMTP (1.5.5)
    Postman LogLevel: 40000
    Postman TCP Timeout (Connection|Read): 10|60
    HTTP User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Thanks for that Mark.. Did you accidentally delete the ‘s’ from smtp.gmail.com? I’m not sure why it says mtp.gmail.com

    But that shouldn’t cause your error. Your configuration is 100% correct. It looks like your issue is a little more complicated than most. Would you mind please emailing me at jason at hendriks dot ca and I will be glad to help you out.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    As discussed over email, Postman is hanging because WPEngine is intentionally killing the request, as evidenced by the HTTP Error 502 in the Javascript debugger:

    "[Error] Failed to load resource: the server responded with a status of 502 (Bad Gateway) (admin-ajax.php, line 0)”

    According to this WPEngine support article, WPEngine kills HTTP requests which take “too long” and respond with error 502.. in this case the web request is Postman’s attempt to send email.

    I will update this thread when I hear back from WPEngine.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    v.1.5.6 of Postman will have code to detect server-side errors during Ajax calls.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    WPEngine’s first response was cookie-cutter, I don’t think they even read what I wrote. Hopefully the second response will come from an engineer.

    They wrote:

    Thank you for contacting WP Engine. If you are getting 502 for the plugin and it is because of the kill request then I would suggest looking into the code. One article I would suggest is about Cookies vs php Sessions.

    Cookies and PHP Sessions

    We do not review/make suggestions on code but this is a place to start to resolving the issue. Please let us know if you have any further questions.

    and my reply:

    Hi, thanks for answering. The plugin uses neither cookies, nor the session. I’m not sure what the article you suggested has to do with the issue I reported.

    In more detail, this problem occurs during an Ajax request to send an email. The user request triggered the plugin to create a request to Gmail, and Gmail responded with an error (HTTP 334) – a totally normal and expected response. I notice when Gmail does not respond with an error (HTTP 200) the request is never killed, regardless of how long it takes. This leads me to conclude that WPEngine is eavesdropping on the plugin’s outbound request and killing the user’s request based on the return code of the plugin’s request.

    I am still asking that you kindly provide a solution for this issue.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    We’re getting somewhere…

    Hi Jason,

    Thank you so much for providing that information. I do believe I was able to replicate the error you’re seeing with the incorrect email entered. I was able to replicate the same messages you’re getting when you enter a wrong email address.

    In rereading your responses I believe I understand that the ultimate goal is to not have that 502 message show when an incorrect email is entered. Your plugin will advise of the incorrect email. Let me know if thats correct just to be sure.

    From here i’m going to escalate the ticket to our senior techs so they can further troubleshoot. If you do have further questions do let us know we’ll be happy to help.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    The last time I heard from WPEngine was Mar 17th, I think their support has given up:

    Thanks for your patience on this. Unfortunately the only extra information I’ve been able to find is that the process is causing a Segmentation Fault in Apache, and since Nginx doesn’t receive any information back, it just displays a 502 bad gateway message.

    That said, I retrieved the full POST information that the script is sending to admin-ajax.php, and also a stack trace of the whole process server-side.

    If you would like to check them out, they can be found in your _wpeprivate folder, but I had some difficulty determining a clear cause from the strace output.

    Since I’m not quite sure what else to check, I’m setting this ticket to the next level of support to investigate further, so if you’re not sure what to make of the strace output, just reply back and it will re-open in their queue.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Test email hangs’ is closed to new replies.