Support » Plugin: WP Mail SMTP by WPForms » Test email failed

  • Resolved ccwtech

    (@ccwtech)


    Trying to use ZOHO Smtp but it appears it want’s to use bluehost (where the site is hosted on)

    Versions:
    WordPress: 5.4
    WordPress MS: No
    PHP: 7.0.33
    WP Mail SMTP: 1.9.0

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP Error: Could not connect to SMTP host.
    Host: smtp.zoho.com
    Port: 587
    SMTPSecure: tls
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: OpenSSL 1.1.1d 10 Sep 2019
    SMTP Debug:
    2020-04-15 16:22:18 Connection: opening to smtp.zoho.com:587, timeout=300, options=array ()

    2020-04-15 16:22:18 Connection: opened

    2020-04-15 16:22:18 SERVER -> CLIENT: 220-box5207.bluehost.com ESMTP Exim 4.92 #2 Wed, 15 Apr 2020 10:22:18 -0600 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.

    2020-04-15 16:22:18 CLIENT -> SERVER: EHLO http://www.arvadavethospital.com

    2020-04-15 16:22:18 SERVER -> CLIENT: 250-box5207.bluehost.com Hello http://www.arvadavethospital.com [162.241.224.194]250-SIZE 52428800250-8BITMIME250-PIPELINING250-AUTH PLAIN LOGIN250-STARTTLS250 HELP

    2020-04-15 16:22:18 CLIENT -> SERVER: STARTTLS

    2020-04-15 16:22:18 SERVER -> CLIENT: 220 TLS go ahead

    2020-04-15 16:22:18 Connection failed. Error #2: stream_socket_enable_crypto(): Peer certificate CN=*.bluehost.com' did not match expected CN=smtp.zoho.com’ [/home1/bouldfk7/public_html/arvadavethospital/wp-includes/class-smtp.php line 374]

    SMTP Error: Could not connect to SMTP host.

    2020-04-15 16:22:18 CLIENT -> SERVER: QUIT

    2020-04-15 16:22:18

    2020-04-15 16:22:18

    2020-04-15 16:22:18 Connection: closed

    SMTP Error: Could not connect to SMTP host.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi @ccwtech,

    Yes, it looks like bluehost is redirecting you transparently to their own mail servers, and you’re likely seeing the TLS certificate verification failures because you’re logging into the wrong server. You might need to contact your host to fix the issue. In the meantime, you can test by disabling the certificate verification. Here’s the code snippet to disable certificate verification. You should not do this unless you have to – it’s compromising your security.

    I hope this helps!

    Hi @ccwtech – We haven’t heard from you in about a week, so I’m going to go ahead and mark this ticket resolved. If you still have questions, though, please feel welcome to continue the conversation

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Test email failed’ is closed to new replies.