Support » Plugin: SG Optimizer » [Solved] Terrible performance when enabled!

  • Unfortunately, I was hoping for the best with Siteground’s own plugin. I activated all the settings and removed AutoOptimize, and have been monitoring for a couple of weeks. But the result is terrible both on GTMetrix (from A to E) and Page Speed Insights (mobile score not even reaching 20%).

    • This topic was modified 9 months, 4 weeks ago by anotherbreed.
    • This topic was modified 9 months, 4 weeks ago by anotherbreed.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Can you give me your site URL so I can look into it. Something seems to be wrong in your config, there’s no way our plugin to make your site perform worse.

    Click here to visit my website. Really hope that is just something not correctly configured and that it can be fixed…

    Many thanks

    Also, please note that Memcached keeps deactivating after a while, can’t figure out the reason.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    I’ve restarted the Memcached service on your account, disabled it and reenabled it. Everything seems to be working fine. I suspect something from previous plugin versions (in which we had issues that were fixed) was causing the problem.

    This said, your backend is a bit slow both with and without memcached enabled. I took the liberty to perform a PHP 7.1 check and it looks like you can safely switch to 7.1 right away – you can do it form the Environment Optimizations – Manual PHP Version check. Don’t bother with the compatibility button. There’s only one error in the wp-related-items-pro plugin which I believe is not critical. I’ve created a php-71-check.log file in your home folder with the error in case you want to contact their developers to look into it.

    This said, switch to PHP 7.1 and I believe your site and your backend will become much, much faster!

    anotherbreed

    (@anotherbreed)

    Switched to 7.1, no improvements so far on GT Metrix and Google PSI. I still have to use Autoptmize to get decent results.

    Also, I started getting some traffic to my non-HTTPS website since the new SG Optimizer, I can notice some data from Google Search Console. Also, the option to “fix insecure content” shows an empty error message popping out, there is no text… maybe that is the reason, but it was working fine before.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    That’s browser cache. Clear your browser cache and delete (deactivate, delete) and then re-install SG Optimizer if it doesn’t flush properly. You will then see everything.

    I too am still finding the memcache toggle in the off position, after it has been on for a few days, on both php 7.1 and 7.3

    I personally perceive the site to load fast from Belgium, memcache on or off, but the stats on GTmetrix, Pingdom etc are not good, even when testing from London when the site is hosted in Amsterdam.

    For the record, nothing is broken, I’m just encountering a few anomalies I’d be curious to know more about, this still being a hobby site. It’s when it (hopefully) becomes our bread and butter certain things need to work better πŸ™‚ I must admit though, I know all too well a poorly configured site will load slow, no matter where it’s hosted, on shared, or even a dedicated server rack.

    ps: I gave 5 stars in my first review, but that hasn’t changed.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Note that memcached handles dynamic requests! This means it should improve speed for you backend, registered users and other dynamic hits. If you have a cached hit on your frontend, it won’t be affected by memcached.

    @sean-h I will look again into that, we’re planning an update and will do my best to have this fixed once and for all. The problem is that ocasionally the memcached service is being restarted and we need to handle that better.

    I learn something new everyday, thanks for clarifying more how memcache actually works πŸ™‚

    Ok, for now it seems that Memcached and Fix Insecure Content switches are ON. It may really be the cache, still it’s weird that I got some data on my non-HTTPS site.

    Now I have to understand 1) why GT Metrix tells me gzip compression is not enabled (when it is) and 2) why the results are still so bad… I opened a ticket.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    I will follow up your ticket since it gives me right to do stuff πŸ™‚

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    I think your site is perfect now πŸ™‚ Check your ticket too!

    Much better, thanks for the help! Still, I will keep using both AutoOptimize and SG Optimizer because it’s the only way to have the best results.

    Looking forward to future updates.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Solved] Terrible performance when enabled!’ is closed to new replies.