• Resolved theotheo

    (@theotheo)


    I remember that when you clicked terms and conditions text on checkout it displayed the terms and conditions page on checkout…Right now it redirects to terms and conditions page on a new tab. How can i make it so that it just shows on checkout as it normally did?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Rafy a11n

    (@nawaz0705)

    Hi @theotheo

    Thank you for reaching out!

    Out of the box, the terms and conditions texts appear on the same page when someone clicks on it. I have just checked my test website and found the same as well.

    Can you please if you are not using any custom code to open the terms and conditions texts on a new tab?

    Thread Starter theotheo

    (@theotheo)

    Hmm so weird then. I use a custom checkout template. While having a custom template it worked as you say by showing terms text on checkout. I didn’t touch anything and from one day to another it just started doing this.Check here, try buying the item to go to checkout check and see how terms text behaves when clicked. (*also remove the link i added once you have checked, thanks).

    • This reply was modified 1 year, 9 months ago by theotheo.
    • This reply was modified 1 year, 9 months ago by theotheo.
    Plugin Support Rafy a11n

    (@nawaz0705)

    Hi @theotheo

    I have checked and found that the target="_blank" attribute is coming from your theme, which is opening the terms and conditions texts on a new tab.

    You can check this screenshot as a reference: https://d.pr/i/geAvd5

    Can you please temporarily disable your theme to a default theme like Storefront and see if the issue is still there?

    also remove the link i added once you have checked

    You can edit your reply and remove the link now.

    Thread Starter theotheo

    (@theotheo)

    Unfortunately changing the theme to storefront didn’t fix the issue.

    Plugin Support Rafy a11n

    (@nawaz0705)

    Hi @theotheo

    Then there is a possibility that the issue is happening due to another plugin, since I am unable to reproduce the issue on my test website that uses the latest version (6.9.2) of the WooCommerce plugin.
     
    The best way to determine this is to:

    • Disable all plugins except for WooCommerce
    • Check if the issue is still there.

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing the conflict. You can find a more detailed explanation on how to do a conflict test here.

    Before you start

    • First, please make sure you have a good backup in place of your full site and database. Most hosting companies have this included in the subscription, but you could also consider using a service like Jetpack. If something goes wrong, it’s nice to know that you can restore your site.
    • Second, I would suggest installing a plugin called Health Check & Troubleshooting. This is a plugin developed by the WordPress community, and it allows you to disable plugins without affecting your current site visitors.
    Thread Starter theotheo

    (@theotheo)

    I wish that would work but it didn’t either. I deactivated all plugins other than woocommerce and i still got the issue. So it’s nether a theme nor a plugin.

    I also checked a woocommerce demo like this wc demo and on checkout the same thing happens. It redirects you to a different page.

    • This reply was modified 1 year, 9 months ago by theotheo.

    Hi @theotheo

    The issue you are describing is not native to WooCommerce. Even I am not able to replicate the behavior on my test site which is running on a basic setup of the latest versions of WordPress, WooCommerce and the Storefront theme.

    I understand that the issue persisted for you even when you disabled all plugins (except WooCommerce) and switched to a default theme like Storefront. Did you do these two things simultaneously? Also, did you also disable any custom code that may be present on the site?

    If it still doesn’t help, then you may need to clear the cache. This article may be useful: https://www.wpbeginner.com/beginners-guide/how-to-clear-your-cache-in-wordpress/

    Thread Starter theotheo

    (@theotheo)

    It’s crazy cause i simultaneously disabled everything and changed theme. When you change theme it doesn’t apply any custom code anyways since all custom functions, code and files are placed into the child theme for example…so no it is not related to custom code either.

    Hi @theotheo

    i simultaneously disabled everything and changed theme. When you change theme it doesn’t apply any custom code anyways since all custom functions, code and files are placed into the child theme

    Thanks for trying.

    Did you try clearing the cache? The change may not be reflecting due to caching of the page. A caching plugin could have saved the page, or may be the browser itself is serving the cached page.

    First, please clear your browser’s cache as explained in this guide:

    I Make Changes and Nothing Happens

    If that doesn’t help then please check whether you have a caching plugin and then purge all cache from it. Next, you’ll want to configure the plugin not to cache the cart, checkout, and My Account pages. Here’s a helpful guide – https://docs.woocommerce.com/document/configuring-caching-plugins/

    These steps should make the page express its normal behavior (i.e., without any influence/interference from any plugins/code/theme).

    If it doesn’t, then in order for us to get a better idea of your setup, please share a copy of your site’s System Status. You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”. Once you’ve done that, paste it here in your response.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Terms and conditions on checkout issue’ is closed to new replies.