WordPress.org

Forums

Temporary fix for WP Dev Blog Feed (in Dashboard) (6 posts)

  1. shorty114
    Member
    Posted 10 years ago #

    Recently, the dev feed got borked by a few extra newlines at the beginning of the feed. This means that the Dashboard will have no dev blog news, and this is a temporary fix until the developers make the fix.

    Here are the instructions:

    1. Open wp-admin/index.php

    2. Go to line 114, which should be something like this:
    $rss = @fetch_rss('http://wordpress.org/development/feed/');

    3. Change the URI to http://shorty114.net/misc/devfeed.php:
    $rss = @fetch_rss('http://shorty114.net/misc/devfeed.php');

    4. Save the file, and all should be fine!

    Just in case you were wondering, this feed is updated realtime from the blog - it isn't a static copy.

    The Technical mumbo-jumbo:

    Basically, this script takes the dev feed RSS and strips the newlines at the beginning of the file, and so then the RSS feed works again.

  2. Joshua Sigar
    Member
    Posted 10 years ago #

  3. Angela
    Member
    Posted 10 years ago #

    Thanks for the tip *& link*... I know some people complain about the feeds on the dashboard, but I love having them there. I've missed them sooo much!

  4. Lorelle
    Member
    Posted 10 years ago #

    This is so easy to do. Thank you for this great and easy fix.

    I was missing these!

  5. shorty114
    Member
    Posted 10 years ago #

    Some people I've heard from don't care for the Dashboard, but some like it, so I made this fix.

    Hope it's simple & easy so everyone can use it...

  6. Simple, easy and fixed - thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic