WordPress.org

Support

Support » Themes and Templates » Templates is missing

Templates is missing

  • Since I startet my new website with customizr, I only get the error message, that the theme needs a stylesheet and a template. I downloaded the theme the normal way from the backend and directly from your website. I did that several times. This is the error message on the themes page. Even my hoster played arround and could not resolve the problem. Would you please help?

    Beschädigte Themes
    Die folgenden Themes sind installiert, aber nicht vollständig. Themes müssen ein Stylesheet und ein Template haben.
    Name Beschreibung
    Customizr Child Das Übergeordnete Theme fehlt. Bitte installiere das übergeordnete Theme “Customizr”, da du Child-Themes sonst nicht nutzen kannst.

Viewing 15 replies - 1 through 15 (of 21 total)
  • WPyogi

    @wpyogi

    Forum Moderator

    That looks like you are using a child theme for Customizr? In that case, do you have the parent Customizr theme installed?

    I just copied the child theme in the folder, that’s why it shows up. I could delete it. I restartet several times without a child theme. I install the customizr theme and get the error message. Of course I installed the parent theme. But you can not activate it, if there is something missing. Same for the child theme of course.

    WPyogi

    @wpyogi

    Forum Moderator

    Where is the child theme installed? In which folder? What is the code in the child theme style.css file? And please post a link to your site.

    It is in the folder “themes”. There are 3 definitions in the css concerning titles. Let me restart once again. I delete the customizr theme, and the child theme and download it again, without child.

    Everything worked so fine on my local computer. Then I uploaded the site in a subfolder. Later on I wanted to copy it one level higher and the problems started. It seems that customizr don’t let me change the path from the subfolder to the mainfolder. The logo was missing for example.

    The URL is http://der-tut-nichts.info/

    Ok, it as activated one again. You see? Nothing changed. Click on Startseite (not the logo)

    WPyogi

    @wpyogi

    Forum Moderator

    So you moved the site? Is that what you are saying the problem is from? In that case, did you follow?

    http://codex.wordpress.org/Moving_WordPress

    How lucky I am. I did everything like described, exept… I forgot the menu. So I try again with the child theme.

    OK, it is the child theme that’s missing something. What files will I need fot the child? I changed some title sizes and added a text-indent for the h1 title. I did that in the WP backend, but I prefere a child theme.
    So now I made a new folder in the themes folder and I uploaded a style.css and a picture for the child theme. And I get the error again.

    WPyogi

    @wpyogi

    Forum Moderator

    What is in the child theme style.css file? (It should not be a copy of the parent theme).

    /*
    Theme Name: Customizr Child
    Theme URI: http://der-tut-nichts.info/
    Description: Child Theme for the Customizr Theme
    Author: Ingrid Libicky
    Author URI: http://der-tut-nichts.info/
    Template: Customizr
    Version: 1.0
    */

    THIS IS NEW – JUST TRYING BUT IT DOES NOT WORK
    /* Import the style.css of the customizr base theme */
    @import url(‘../customizr/style.css’);

    h1 {
    font-size: 38px;
    line-height: 38px;
    }
    h2 {
    font-size: 20px;
    margin-top: 1.5em;
    }

    h3 {
    font-size: 17px;
    margin-top: 1.5em;
    }

    h1.entry-title {
    text-indent: -61px;
    padding-left: 61px;
    }

    .by-author {
    display: none;
    }

    /* Not working */
    .navbar .nav {
    font-family: Karla, Arial;
    }

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Are you sure you should be using a capital C in the “Template:” ?

    Oh holy…. does that matter? mpfff….

    WPyogi

    @wpyogi

    Forum Moderator

    Yes, it matters greatly :)!

    Yeah! Why did that work local on my computer but not on the server? Such a silly mistake!

    Do I need to import the style sheet of the base theme?

    And the last one: How can I format the subtitle (upper right)? You see the last entry in my css. It’s not working and I don’t have any other idea.

    WPyogi

    @wpyogi

    Forum Moderator

    Can you activate the child theme? Did you add that font?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Templates is missing’ is closed to new replies.