Support » Fixing WordPress » templates, index and apache error?

  • I was trying to edit my index file to include an author template. Now I’m getting this error:

    Warning: main(/usr/local/psa/home/vhosts/ failed to open stream: Permission denied in /usr/local/psa/home/vhosts/ on line 17

    Warning: main(): Failed opening ‘/usr/local/psa/home/vhosts/’ for inclusion (include_path=’.:/usr/local/psa/apache/share/pear:.:.’) in /usr/local/psa/home/vhosts/ on line 17

    I see the word ‘apache’ in there and that scares the shit out of me. What did I do? I’ve re-uploaded the old files for the index.php and template-loader.php (just for good measure even though I never touched it) but I’m still seeing this error.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You will have to a bit more specific about what you are trying to do: how exactly are you “including” the author template in an index? What is the filename? Why author template inside the index?

    In the index file (index.php) of the theme that I’m trying to customize, it already had a section to include <?php _e('Author'); ?> (it was disabled by default) and upon changing that to include it and uploading it, things got all screwed up and the theme no longer works, giving me the above message. Other templates work fine though. I’ve re-uploaded the original files, but it doesn’t do jack.

    <?php _e('Author'); ?> <== this one is not supposed to include anything. It will just display the word “Author”. Nothing else.

    Ok. That’s bizarre then. This is the only thing that I’ve done to this theme and now it doesn’t work. Time to delete the whole folder and start over maybe.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘templates, index and apache error?’ is closed to new replies.