Template's gone... Login's gone... Arrgghh... (8 posts)

  1. robirwin
    Posted 10 years ago #

    Earlier this evening, I upgraded to the latest version of WP. Everytime I'd make a new post, however, I'd get a referrer error. One possible solution I read about was to edit the sites address in Options.

    So, rather than having http://www.robirwin.com/iliketowatch on the Options page, I changed it to just read /iliketowatch in both the fields where you can have a URL. As this didn't seem to do anything, good or bad, I decided to change it back to the full address because I wasn't entirely comfortable with it.

    Then the problems started!

    If you look at http://www.robirwin.com/iliketowatch you'll see that the template had disappeared.

    Further I can't access http://www.robirwin.com/iliketowatch/wp-admin

    [But try http://www.robirwin.com/iliketowatch/wp-admin/install.php and you can clearly see that WP is installed and appears to be OK.]

    What can I do? I've tried a few little tricks from postings on here, but nothing seems to help... yet it's probably something quite simple.

    Can anyone please help?

    Posted 10 years ago #

    The URL's been borked somehow. If you look at your links, they re-duplicate, ie.

  3. robirwin
    Posted 10 years ago #

    Thanks for noticing that. I wonder what it means? What causes it? Is there a way to hack into my settings (maybe through myPHP)?

    Posted 10 years ago #

    You have a mistyped relative URL somewhere or you've missed the http:// part in something. That's what normally causes it.

    I.e, if you make an anchor to say http://www.doesntexist.tld rather than http://www.doesntexist.tld it'll appear as

  5. robirwin
    Posted 10 years ago #

    So this probably should have happened when I just put /iliketowatch in the box on the options page, ie: I didn't put a full URL, let alone start it with http://

    Thing is... it worked OK when I did that. It only broke when I re-entered a full URL, including http://

    Posted 10 years ago #

    You mean for the base URL of your blog? Yep, it was meant to be a full canonical URL, http:// and everything.

  7. moshu
    Posted 10 years ago #

    The two URIs in the Options > General should be full addres, e.f. http://example.com/blog
    no slash at the end and no filename at the end.
    If you messed up, and cannot access the admin interface, try this guide of Podz:

    (just out of curiousity: are you using some kind of redirect, parked domain and stuff like that?)

  8. robirwin
    Posted 10 years ago #

    Whoo! Thanks Moshu... I followed that guide, and it's fixed. Many thanks :)

    I think the problem was I had dropped the http:// even though I was sure I hadn't...!

    For the record, no, I'm not forwarding or doing anything bizarre. It's a straight hosting setup.

Topic Closed

This topic has been closed to new replies.

About this Topic