Support » Plugin: Pods - Custom Content Types and Fields » templates disappeared

  • Resolved criticaltinkerer

    (@criticaltinkerer)


    I recently tried to view one of my Pods-created content types. The archive view seems intact (all custom fields appear as they should) but single post view only shows one field. I went to check the temples and the admin menu >> Pods >> —templates is missing from the menu. I tried to direct access is with wp-admin/edit.php?post_type=_pods_template and I get an error: Invalid post type.

    The above error was triggered by Core.I tried deactivating/reactivating. I tried deleting and replacing the Pods plugin (from the file system).

    WordPress Version: 5.3.2
    PHP Version: 7.3.13
    MySQL Version: 5.5.5
    Pods: 2.7.16.2
    Pods Network-Wide Activated: Yes

Viewing 9 replies - 1 through 9 (of 9 total)
  • Update:

    On my other network site admin menu >> Pods >> —templates does exist, so problem appears to be isolated to one site on the multisite installation.

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @criticaltinkerer

    Are you sure the Templates component is enabled on that site? Pods does not office network wide settings so templates should be enabled on every site in a network manually.
    Let me know!

    Cheers, Jory

    Most of the components, including Templates have disappeared. Only the following components show up o that site:

    • Builder Integration
    • Migrate: Import from the Custom Post Type UI plugin
    • Migrate: Packages

    Is there someplace else to activate components other than Admin >> Pods Admin >> Components?

    criticaltinkerer

    (@criticaltinkerer)

    I’m sure there is a simple fix for this…. if only someone would be kind enough to respond.

    Harry Hobbes

    (@harry-hobbes)

    I had an interesting experience recently which I will share, as it may help you recover.

    I recently transferred several websites from one hosting provider to another using plug-in backup tools which dumped the WordPress sites in a format that was readily importable/buildable on the new host servers. However, when I logged into the transferred websites, the websites seemed to have a variety of plug-in “idiosyncrasies” that were driving me in circles when trying to resolve. I deactivated and uninstalled various plug-ins to determine whether these were causing the problems, but I couldn’t make any headway at diagnosing exactly what was causing the problem.

    Eventually, I got into cPanel and phpMyAdmin to look at the WordPress tables.

    Here is what I discovered:

    It seems that many, many plug-ins leave tables and records in the WordPress database when the plug-ins are deactivated (or uninstalled). This includes PODS, which leaves tables in the “options” table and the “postmeta” table. Depending on the plug-in, this residual data may play havoc should the plug-in be re-installed.

    Once I deleted all references to non-existent plug-ins, and all plug-ins that I had deactivated, the “idiosyncrasies” disappeared. (Caveat emptor: I tend to “try out” plug-ins; hence, I had a lot of left-over data records and tables from uninstalled plug-ins.)

    My big takeaway from the day I spent cleaning up the database was that leaving data behind in the database seems to be normal operating procedure for plug-ins, and in order to keep the database “clean,” one must manually check the database for left-over data. Checking the database can easily be accomplished by “export[ing]” the table as an .sql file, and reviewing it with a quality editor (such as Notepad++). PODS data may be found by searching the file for “pods.” Should you do this, ensure you make a backup of the database before making any changes.

    Needless to say, keeping the database cleaned up is now one of my recurring tasks.

    criticaltinkerer

    (@criticaltinkerer)

    Hello @harry-hobbes,

    Thanks for sharing your experience! Your advice pretty much aligns with what I’ve been dreading sinse the problem started: Dig deep into the tables and do some housekeeping. On the bright side, I have a relatively recent backup/clone of the site which has no problems, so I have some comparsion data to work with.

    While I’m still hopeful for a quick fix, it looks like I’m going to have to spend a solid day on this.

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hi @criticaltinkerer & @harry-hobbes

    Pods has cleanup options within it’s settings.
    Deactivating Pods doesn’t remove data to prevent loss of data. If you want to remove all data from Pods this also can be done from the settings pages.
    Removing a pod truly removes that data from the database. However, this does not remove any posts/taxes created within that pod. If you really wat to remove the entries itself you can do this before removing the Pod itself.

    Now on the actual topic. I think this might be a cache issue. Could you try and clear the cache under Pods > Settings?

    Cheers, Jory

    criticaltinkerer

    (@criticaltinkerer)

    Thanks @keraweb,

    Loosing data is what I’m trying to avoid so I won’t be reseting Pods any time soon. Anyway, deleting Pods is complicated by the fact that this is a multisite WP installation (for which, on my other site on the network, Pods happens to be working just fine).

    What would like is to understand more about how Pods implements its Components and what would make them disappear. My templates exist… I just can’t access the Template component to be able to edit them. Perhaps @jimtrue would be kind enough to chyme on how to re-activate the missing components.

    As it stands, my only option seems to be to follow @harry-hobbes ‘s advice and looking for database issues. At least I have a relatively recent clone of the site I can use for comparison.

    Plugin Author Jim True

    (@jimtrue)

    Network Multisites just make most of this complicated. If it’s working on another site within your network and it’s not working on that particular site, you’ve probably got a conflict of some kind.

    Also check your roles & capabilities for the access on that particular site.

    My suggestion if you’re still having issues is to bring it to our Slack Chat or open a Bug Report, but since we’d have to completely replicate your situation, that would be more of an edge case.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘templates disappeared’ is closed to new replies.