Support » Fixing WordPress » Template won’t load: “Template is missing”

  • Resolved illovich


    I’m making a template for my blog, and I’ve run into a bit of trouble. I uploaded my files to a directory manually with an ftp program, and although WP can find the template, it gives me an error about the template being incomplete, specifically that the template is missing.

    From my research, I know that the the template is the index.php file. This is not missing, it can be requested from my server (although of course the get_header() function throws an exception).

    What I’ve tried:

    • I’ve checked to make sure that the style.css and the index.php file exist.
  • I’ve confirmed that my ftp program is sending the php and css files as ASCII and not binary (although I’ve never had a problem with that on this server before)
  • the style.css file has the comments in the front
  • I’ve checked permissions on my directories and files… 755 and 644, like the other templates
  • Can anyone think of something else I can check?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Make sure you have header comments in the style.css file which reference the theme name. See like files in the default and classic themes.

    Oh – nev’mind – I see that you ref’d that…. sorry…. hmmm.

    No thoughts then right now….

    I sort of figured it out, but I’m going to leave it as unresolved… I had copied the theme setup from the Theme_Development page, which was this:

    Theme Name: Rose
    Theme URI: the-theme’s-homepage
    Description: a-brief-description
    Author: your-name
    Author URI: your-URI
    Template: use-this-to-define-a-parent-theme–optional
    Version: a-number–optional
    General comments/License Statement if any.

    I deleted the line that says “Template: use-this-to-define-a-parent-theme–optional” and the theme was selectable in my Presentation tab and I was able to activate it, but now it’s gone so I can’t get it back if I switch to another theme.

    But it’s working, which is kind of weird… obviously WP can find the index.php and style.css pages because my blog is working.

    So it’s getting stranger.

    In case it helps (like there’s something else wrong with my style.css file, here’s what I have as my template setup:

    Theme Name: illovich
    Theme URI:
    Description: This design is for If you like it enough to nick it, let me know =P
    Author: illovich a.k.a. p-marx hanley
    Author URI:
    Version: 0.1

    What do you mean by “its gone”?

    When you selected another theme, is the illovich theme still visible within your Admin >> Presentation >> Theme panel?

    Has the screenshot and templates vanished from the Theme Panel and Theme Editor screen? Or from your website (what people see) and there’s no visible “link” in which to select the illovich theme while using classic or default themes?

    When you selected another theme, is the illovich theme still visible within your Admin >> Presentation >> Theme panel?

    Yes, that’s what I mean. My theme is working fine as far as I can tell, but when I go to the theme selector page, it’s not in the list and at the bottom of the page I still get the “Template is missing” message.

    Okay. Another question. When you uploaded your theme via FTP, it looks like this?

    —classic (folder)
    —default (folder)
    —illovich (folder)
    —-images (folder)

    Yes, that’s the directory structure. The files themselves live here:

    I put a page up here
    for testing it before whatever I did made the theme show up for a minute in the Presentation:Themes selector page.

    Everything is fine for the moment, but the symptom tells me something is wrong, and I’d like to figure it out so I don’t have a nasty surprise in the future…

    Okay. I get the same theme style when I go to so your theme’s definitely working – at this point.

    Sorry for the bump, but I was hoping maybe some fresh eyes would see. I realize now that my terminology in my original post was off — it’s my Theme is not showing up in the Theme selector.

    The error given is “Template is missing” which is part of what led to my confusion. As another point though, I can use the theme editor to edit the files of my “illovich” theme, and the index.php comes up as the Main index Template in the theme editor, so my mind is boggled.

    Is there another template I might need?

    As another thought, is there maybe some other way to check the theme that would give more information than “Template missing”?

    Like maybe something that would output

    Error in theme: Template referenced in line xx in file file.php not available

    or something like that?

    I see a very nice layout, colors (grey and vanilla creme), nifty blockquotes with dashed borders…. some interesting commentary (loved the “codswallop” about the Roman Empire and the Barbarians!) – so yes, if that’s what your theme (illovich) is supposed to look like, then at least it’s displaying properly.

    Why it’s not showing up as a selectable theme in wp-admin/presentations, I couldn’t say. Have you tried reuploading the entire wp-admin and wp-includes folders, just in case something’s corrupted somewhere?

    This has been bugging me for a while, and in a fit of annoyance at not wanting to reinstall wp, I tried deleting and re-uploading my theme.

    This fixed my problem (sort of) in that now my theme is selectable in the theme selector, but it still lists as being broken at the bottom “Template is Missing.”

    Bleh. I’m going to mark this as resolved and hope I never have to bring it up again. 🙂

    Thanks for your help, guys!

    I was experiencing the same problem with a theme that I made, and with another that I downloaded. The solution for me was just to delete the “Template:” line completely from the style.css

    I had:

    Template: therks
    Theme Name: therks
    Description: WordPress theme for

    I just removed the first line, and it works fine. I decided on this cus I noticed that in both the included themes (default and classic) neither style.css had this line.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Template won’t load: “Template is missing”’ is closed to new replies.