WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Template problem in 2.1.3

[Resolved] Template problem in 2.1.3

  • I have a page titled “Archive” with page slug of “archives” that’s associated with a custom template that displays a list of the archives by month and category.

    This was working fine on 2.1.2, but after the upgrade to 2.1.3, that page displays a list of articles — as if it were using the default template for the home page, not the custom template.

    I can create a new page with my custom template and it behaves correctly. Other custom templates are behaving correctly. I’ve tried changing the page slug, the name of the template file, the name of the template, and the name of the page but still get the wrong content on the page. There’s no other content on the page and the link to the template file looks correct in the wp_postmeta table.

    I’m doing this in a QA environment, so would like to understand what’s going on before upgrading production.

    See screen shots if you’d like to see my confusion. Any pointers would be appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Never mind. I can’t reproduce this.

    Followed your example on a newly installed 2.1.3 blog using the wp-content/default theme and I couldn’t duplicate your problem.

    [edit]
    Oops see you came to same conclusion 😉

    I should have clarified this.

    When I did the upgrade using my hosting services 1-click upgrade, I had the problem with the archive template.

    When I did the upgrade “by hand,” deactivating all the plugins before applying the upgrade. All went well.

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Template problem in 2.1.3’ is closed to new replies.
Skip to toolbar