Support » Plugin: Theme My Login » Template not being used

  • Resolved Glen Scott

    (@glen_scott)


    Hi,

    I have the following setup (with TML 7.0.11):

    A page named “Login” with the slug login
    A page template used by the login page that contains the following PHP code:

    <?php echo echo do_shortcode('[theme-my-login action="login"]'); ?>

    A TML template named “login.php” in my theme.

    However, the problem is the “login.php” template is not being used at all — the form being rendered is the standard TML one. How can I override this?

    Thank you,

    • This topic was modified 3 months, 4 weeks ago by  Glen Scott.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeff Farthing

    (@jfarthing84)

    You’re calling the shortcode, though. That would render the default TML form…

    Hi Jeff,

    Thanks for replying. The reason I ask about this approach is that it worked as expected in version 6 (albeit with a template named login-form.php rather than login.php). I was expecting the same approach to work with version 7 but you are saying this is not the case?

    Glen

    Plugin Author Jeff Farthing

    (@jfarthing84)

    TML 7 does use templates, but not in the way 6 did. More in the way WP does – meaning there is a hierarchy of templates to represent the whole page, not just the form as was the case in 6.

    Thank you for being so responsive. Appreciate it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.