Support » Themes and Templates » template is not getting updated

  • Resolved rukusphil


    i’ve been pulling my hair out trying to troubleshoot this all day. your help is very much appreciated!!

    for the wordpress site i’m working on, i’ve created several custom templates (by copying and modifying other templates) and they have worked really well. everything was going well until today.

    earlier today i created a new template (let’s call it Template A), and choose it from a new page (Page A). it saves properly – when i view Page A in the admin dashboard it shows Template A selected.

    problem is: when i view Page A, it is displayed with the default template instead of my custom template.

    i thought i might have made a syntax error, so i started fresh – copying an existing, working template and only changing the template meta info at the top. it still shows the default template.

    as i desperately tried different things, i found that modifying existing, working templates didnt cause the associated pages to change. e.g. if Page B uses Template B, i went into Template B and added dummy text to be displayed, and it is not displayed in Page B.

    more interestingly, i removed text that was hardcoded into an existing, working template (Template C) and it still shows on the associated page (Page C)! it’s like phantom text. the specific string is not found anywhere else in my source code, but it still displays when i view the page (Page C).

    i’m using the responsive theme but these doesnt seem like it’s a problem with that specific theme.

    i thought it might be a cache problem, but i’m not using any kind of wordpress cache, and i tried to disable my apache cache (i’m running the site on my local env, which is a mac).

    i also cleared my wordpress revision history by deleting all “revision” post types from the database.

    does anyone know what might be causing all of this strange behavior????

    thank you in advance!

Viewing 1 replies (of 1 total)
  • found out what i was doing wrong.

    i moved my source code root and didnt change the .htaccess file.. so the web server was actually loading pages from my old source code directory.


Viewing 1 replies (of 1 total)
  • The topic ‘template is not getting updated’ is closed to new replies.