Support » Theme: raindrops » Template functions.php error

  • Resolved john_graver

    (@john_graver)


    Hi, Nobita,

    The site now displays the following errors:

    Warning: Trying to access array offset on value of type null in /data/web/virtuals/124470/virtual/www/domains/skkp-karate.cz/wp-content/themes/raindrops/functions.php on line 11189
    Warning: Trying to access array offset on value of type null in /data/web/virtuals/124470/virtual/www/domains/skkp-karate.cz/wp-content/themes/raindrops/functions.php on line 11211
    Warning: Trying to access array offset on value of type null in /data/web/virtuals/124470/virtual/www/domains/skkp-karate.cz/wp-content/themes/raindrops/functions.php on line 11167
    Warning: Trying to access array offset on value of type null in /data/web/virtuals/124470/virtual/www/domains/skkp-karate.cz/wp-content/themes/raindrops/functions.php on line 11254
    Warning: Trying to access array offset on value of type null in /data/web/virtuals/124470/virtual/www/domains/skkp-karate.cz/wp-content/themes/raindrops/functions.php on line 11276
    Warning: Trying to access array offset on value of type null in /data/web/virtuals/124470/virtual/www/domains/skkp-karate.cz/wp-content/themes/raindrops/functions.php on line 11232

    Not sure since when but recently I switched the hosting to PHP8. My other site with the same template and also on PHP8 doesn’t show these errors.

    Regrads,
    John

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Theme Author nobita

    (@nobita)

    Hi @john_graver

    You can stop the error display by adding a line of code to this file.

    wordpress install directory / wp-config.php

    Change from

    
    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    

    to

    
    <?php
    define('WP_DEBUG_DISPLAY',false); // Please add only this one line
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    

    Note:
    Raindrops theme and WordPress Core(ver5.8.1) does not fully support PHP8.

    The cause of this error is in the theme, but since it is not possible to update immediately, I explained how to not display the error.

    Not only the theme, but also the core is not fully supported, so you may get an error message that you do not notice somewhere, so it is recommended to change it on all your sites.

    Thank you.

    Thread Starter john_graver

    (@john_graver)

    Hi Nobita,

    Thanks for the hint. I actually don’t need the php8 – the site was just upgraded to te highest available version. I have downgraded to php7.3 but it didn’t help. I have added the variable WP_DEBUG_DISPLAY but unfortunately the errors are still displayed.

    regards, John

    Theme Author nobita

    (@nobita)

    Your site currently seems to have the cache plugin enabled.
    Please check if it does not disappear even if you press the clear cache button in the admin bar

    If you still get the error, we will consider updating the theme so please let me know the result.

    Thank you.

    Thread Starter john_graver

    (@john_graver)

    Hi Nobita,

    Thanks – after disabling/reenabling the cache plugin the error messages apear no longer.

    regards,
    John

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.