WordPress.org

Support

Support » Plugins and Hacks » Pods - Custom Content Types and Fields » [Resolved] Template code editor is reverting html brackets to entity codes

[Resolved] Template code editor is reverting html brackets to entity codes

  • I have a fresh install, latest Pods (and I just double checked by diff), creating or importing templates. When I update the template, it reverts brackets into their lesser than/greater than entity codes (and funnily enough, if I save it again, it turns the ampersands into the amp code, on and on and on…).

    I made a screenshot showing the reversion.

    I’ve turned off all plugins, and cleared the cache in Pods, as well as for WPEngine, and I’ve tested in Firefox and Chromium (with cleared caches as well). I found issue #2207, but I am not have the same issue as that (my template box is showing). Debug info is up as a paste.

    I’ve checked it against other instances of CodeMirror, such as with the Code Snippets plugin, and it works correctly. I’ve also checked, and there isn’t a second instance of CodeMirror being loaded on the template pages.

    I am stumped. What else can I check?

    https://wordpress.org/plugins/pods/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Josh Pollock

    @shelob9

    The next thing left to check is that this is not a theme issue. Try switching to the default theme and then see if it still happens.

    Also, do you get the same behavior with Pods Frontier activated?

    Sidenote (first!): I didn’t know the Frontier and Frontier Auto Template were two different plugins. That seems like it could be named differently, or the connection made more apparent in their respective docs. ^_^

    I was hoping that was it, but neither of those worked. TwentyFourteen with/without Pods Frontier, still stripping my HTML out. Curly brackets are fine, though (I noticed in a different template).

    There haven’t been any other reports of this, ne? Bummer, I always seem to get weird outlier issues. T_T

    Any other thoughts, Josh? If it is worth your time, I can create admin/SFTP accounts for ya. Right now I am going to reproduce the site elsewhere and see if that changes anything. If you’d like to play along at home, the deployment repo is at https://allthecod.es/westview-press/wp-deploy.

    I spun up a Digital Ocean server and cloned the deployment repo, and the code editor is working. Next I will try spinning up another instance on WPEngine. Blah.

    Plugin Contributor Josh Pollock

    @shelob9

    I’m honestly stumped as to why this is happening to you. If you can’t reproduce it in any other environments and I can’t reproduce it here, which I can’t it is impossible to know what’s up. Let’s hope it goes away and stays away on its own.

    RE: Frontier/ Frontier Auto Template- Yah, good point, but too late now. Auto Template will probably eventually become part of Frontier at some point, but since it was a simple thing we could get done before finishing Frontier it made sense to release it on its own. It was originally called Omega Pods, which was just dumb…

    I am gonna resolve this thread, though I never figured out what the issue was. I deployed from that repo to a non-WPE server, and it worked fine. And I provisioned a new WPE instance, and Pods worked fine there, but if I use WPE’s copy install feature, the new instance also has the issue. So something got messed up that is copied over, but I don’t have time to resolve it (we are going to deploy elsewhere).

    Thanks for your assistance, Josh. ^_^

    Plugin Contributor Josh Pollock

    @shelob9

    Yah, that’s very weird, but if you decide to track down the cause, I think you’d be better off talking with WPEngine support.

    For what it’s worth, I have the same problem as Maiki had.

    I’m using 1&1 in Spain for hosting. Right now I don’t have any spare time to investigate it further – it happens on a test site I have, and I can copy the template back from production when it gets corrupted. Every time I save it, it is displayed corrupted, but seems to continue working just fine (!). But just so you are aware that there does seem to still be a latent problem lurking here, Josh.

    Here’s a template which got corrupted after saving on the test site:
    <tr><td id=&quot;td_{@category.course_code}&quot;><a href=&quot;/{@category.description.post_name}&quot;>{@category.course_code}</a></td><td>{@start_date, format_date_jSFY}</td><td><a href=&quot;/author/{@tutor.display_name, format_name_slug}&quot;>{@tutor.display_name}</a></td><td>{@towncity}</td><td>{@cost}</td></tr>

    Wow – the code has been pasted here in re-constructed form. Didn’t expect that…

    Plugin Contributor Josh Pollock

    @shelob9

    @sqeze – This should be fixed in Pods 2.5.2

    Many thanks, Josh!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Template code editor is reverting html brackets to entity codes’ is closed to new replies.
Skip to toolbar