Support » Installing WordPress » Fatal error: Allowed memory size of 16777216 bytes exhausted

  • i have just installed the 2,7 wordpress
    and when im trying to install it i can see step 1

    Blog name and mail.

    then when trying to get du step 2 the browser answeres

    “Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 30720 bytes) in /usr/home/web/web276672/lan/wp-admin/includes/template.php on line 3186”

    I have tryed to delete all unesesary content ins my mysql database but that does’nt work, then i tryed to make the “/wp-admin/includes/template.php” file to write in my ftp, 0677 but that does’nt work either, what to do know?

Viewing 8 replies - 1 through 8 (of 8 total)
  • It’s likely not a problem with your database, but rather a need for more PHP memory. Methods for increasing the amount of memory a PHP script may consume:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 16M try 32M:
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)

    2. If you don’t have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 32M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '32M');

    4. Talk to your host.

    Also, make sure you use ASCII transfer mode when FTPing files to your host (Uploading WordPress to a remote host).

    Also info on Changing File Permissions.

    Howdy!

    I have the same problem:
    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 77824 bytes) in /home/domains/athlan.pl/subdomains/flashmob/root/wp-admin/admin-header.php on line 122

    But 16777216 > 77824, so I can’t belive that. I’ve defined 2 lines at the begging of index.php:

    ini_set('memory_limit', '32M');
    define('WP_MEMORY_LIMIT', '32M');

    Any ideas?

    you need to put this in wp-config.php not index.php

    define('WP_MEMORY_LIMIT', '32M');

    personally I would make it 64M

    FoxSmith

    (@foxsmith)

    I changed the php.ini file and de wp-config.php but I still recived this error… I Have wp 2.8.4

    Samuel B

    (@samboll)

    FoxSmith
    ask your host to kindly bump the php memory to at least 32M

    Thanks for posting the fix, I just had this updating to 2.9.1 – but my ‘exhausted’ message was for 33 million bytes. 64M did the trick. 64M should be enough for anyone, right? ;p

    Had the same problem upgrading to 2.9.1. Used samboll’s fix set to 64M.

    Thanks.

    I am having the same error and I have tried to bump my php memory limit via php.ini and wp-settings.php at the same time as high up as 512M and the error still shows.

    Please help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Fatal error: Allowed memory size of 16777216 bytes exhausted’ is closed to new replies.