Support » Theme: Neve » Tel Link Not Working

  • Resolved elmtreedev

    (@elmtreedev)


    I created a tel link in an html box in my header. I cannot get the page to recognize it as a link, or make it clickable. When I inspect the value, it displays correctly, but it won’t become clickable for anything. I’m not sure if it has something to do with all of the nested elements, but it shouldn’t matter. Is there something in the theme files that is deactivating it?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • marties

    (@marties)

    hi,

    your link looks like this
    href="tel://951-808-7930"

    and i think it has to be that way
    <a href="tel:+33500000000">Link text</a>

    Thread Starter elmtreedev

    (@elmtreedev)

    @marties, I have tried it with hyphens (-), without hyphens, with the //, and without. Having hyphens or not hasn’t made any difference. If I don’t have the // (so it just looks like tel:951-808-7930) it pulls the domain in with it and tries to run the number as https://myrmortgage.com/951-808-7930.

    • This reply was modified 7 months ago by elmtreedev.
    Mat

    (@mateithemeisle)

    Hello @elmtreedev ,

    Thank you for using Neve and for reaching out!

    This is the code that you need to paste in the HTML component in the header:
    <a href="tel:9518087930">Call us at (951) 808-7930</a>

    Thank you and please let us know if this worked for you!

    Thread Starter elmtreedev

    (@elmtreedev)

    @mat,

    Thanks for the suggestion. That is actually the first way I plugged it in, since that is pretty straight-forward tel link syntax, but it doesn’t work. I did try it again just to be sure, and it still isn’t working.

    I’m not sure if there is something in a parent element that is breaking the link. When I add a cursor element to the tel link it doesn’t recognize that either.

    Any other ideas?

    Thread Starter elmtreedev

    (@elmtreedev)

    @mat,

    I was curious about something and played with the frontend side more. In doing so I found that I can’t select/highlight the number number text at all in either desktop of mobile views. Something seems to be making it so it is not interactive.

    luciamarinescu

    (@luciamarinescu)

    Hi @elmtreedev!

    It seems like you added a lot of custom CSS to place the phone number above the button and this overrides the elements of different rows. Thus, that text can’t be clicked or selected/highlighted. The solution would be to remove that custom CSS, as you can see here.

    Have a nice day!

    Thread Starter elmtreedev

    (@elmtreedev)

    @luciamarinescu

    That was exactly it! Thank you.

    @elmtreedev Wonderful, I’m glad it works properly now, thanks for letting me know! It would be great if you could mark this thread as resolved.

    Thank you and have a nice day!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Tel Link Not Working’ is closed to new replies.