Support » Plugin: W3 Total Cache » Technical Consultation

  • Resolved atutrabajo


    Hello. I have the following problem, with your plugin in general and with the browser cache in particular.
    The issue is more or less like this:
    a) The context
    a.1) This is the configuration I have for the browser cache;

    a.2) Here between us, out of all this “kilombo”, the only thing that (from the little I understand about it, heh:) could be causing me some “problem” is that, the configuration of…
    Performance/Browser Cache/Html & XML, it looks like this;

    That is to say, on the one hand I activated…
    Set header expiration/Header expiration:
    And I put it as a value; 1 second
    And, on the other, I put….
    Set Cache Control Header/Cache Control Policy:
    With the value; “no cache (max age = 0; private; no store; no-cache; must-revalidate)”
    That between us, I have no fucking idea what this implies, heh. () () You will tell me yes, this is causing the problem that I am going to describe to you.

    a.3) On the other hand, in…
    Performance/Minify/JS I have included;
    Which is who commands the header and footer of my site.
    And I added it in;
    Before the head/No blocking using async

    a.4) Finally, in…
    Page Cache/Cache Preload, I have the following (*);

    (*) For “obvious” reasons, before taking the screenshot, I replaced the name of my site in the sitemap, by – precisely – the word mysite, heh.

    I add it to you – also – because once (when I asked you something similar) you told me that I could solve what I will describe below, with…
    Performance/Purge Module/Browser Cache: Update Media Query String
    But not.

    Now what is the problem?
    b) The problem
    Every time I make a change to my pages or posts (i.e. when I edit them), the following happens:
    b.1) In an incognito browser, when accessing my site from a link, it looks like this;
    I mean, the header looks perfect (as it should be, heh).

    b.2) But, when I send said link (for example by mail) and they click on it, it looks like this;

    Obviously, if the visitor refreshes the page, the header will look good. But…
    You and I know that, unless they feel it is necessary, NO visitor will do that.
    Ergo, the header in question will look “horrible”.

    So I ask you, what do I have to do so that this does NOT happen?

    I await your comments.

    From already thank you very much.


    PS: I understand that it could reduce the page preload time. But you and I know that this would consume a lot of resources on my server. Ergo, I would need another type of solution, okay?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter atutrabajo


    Another yes, I say.

    Oh. I forgot that – also – I have the following problem…

    As you can see in the screenshot above, in addition to a header and a footer, created with the Elementor Header & Footer Builder plugin, precisely in an Elementor template (Hello Elementor) which, in case you don’t know, comes without these elements (neither header nor footer), in my hompage (the one you see in the screenshot), I chose to add a numerator.
    The same (included in the plugin), loads (or should load), from 0 to certain numbers (*)
    [(*) I have to update them but, for now they are; 249,682, 415,910 and 14,000,000]

    The problem is that, from time to time, what you are seeing in the screenshot happens.
    That is to say, the numerator does NOT work! (**)

    [(**) And that, what you are seeing, is in an incognito window]

    And this, just as I told you about the header, is also “fixed” if the visitor refreshes the page. But you and I know that this will NOT happen if said visitor does not think it is necessary.

    Ergo. The numerators will remain at 0 and will generate the opposite effect to the one I am looking for (***)

    [(***) This is to let them know that they actually have A LOT of employment opportunities, heh]

    Finally, and regarding this last inconvenience:
    If you want, you can analyze my source code to see if there is something from all the files (JS and/or CSS) that, I am;
    a) Minifying + Adding to the Head + Not blocking using async and/or
    b) Minifying + Adding before closing the body + Not blocking using defer and/or
    c) CSS minify settings: Enable
    Minify method: Minify only
    Minify engine settings: Remove protected comments (does not apply when “merge only” is active)
    Line break removal (does not apply when “merge only” is active)
    @import handling: None
    d) Loading scripts after a timeout when there is no user interaction (5s) but NO Minification (****)

    [(****) The latter, of course, I do with another plugin – Flying Script – well, yours does NOT have it]


    Just in case, the scripts that are in a) are NOT in b) or d) and vice versa 🙂

    I await your comments.

    Like always, thank you.


    Plugin Contributor Marko Vasiljevic


    Hello @atutrabajo

    Can you please confirm that the site in question is the URL you shared (staging)?

    If so, I’ve checked your website numerous times and tried various browsers, however, every time the header looks as it should look and the counter always shows the same result (no 0’s)

    SO can you please share if this is the correct website URL and the specific browser you are seeing the problem on?


    Thread Starter atutrabajo


    Hello Marko. Thanks for answering.

    And yes, the site in question is and, as I said, the problem is “occasional”.

    This is, sometimes it happens (like the screenshots I sent you), and sometimes it doesn’t.

    In fact, in an incognito browser, it works fine for me. But, when I send a link out there (for example by mail), the site that, obviously, will be seen in a “normal” browser, looks HORRIBLE.

    And I understand that it is a cache issue + minified because, after a while of making a change (editing) a page or an entry, the problem is solved.

    Because? Because in my W3TC I have activated the page preload in 10 pages every 10800 seconds (3 hours). And, since I have 32 pages + 8 posts (40 pages), the ENTIRE site is preloaded, every 12 hours.
    But NOBODY is going to come back 12 hours later yes, the 1st. Once you enter, the site looks “ugly” and/or the numerator is set to 0.

    I hope it is understood.


Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.