Support » Plugins » TDOMF – Permissions Problem

  • Havinga real problem with user access which only manifested itself recently (I have been using successfully for 18 months); I can’t be certain when it first occurred (as admin I don’t see it)!

    On the “Form 1 Options” Page under “Who can access the form?” I cannot enable the “Author of post (registered users only)” field.
    Under “Roles” I have all boxes ticked but – unless I enable The “Unregistered Users (i.e. everyone)” field, Contributors are unable to access the form (Message reads “You don’t have permission to access this form”)!

    I don’t want to enable “Unregistered Users (i.e. everyone)” (for obvious reasons)…
    Do you have any idea why I can’t enable the “Author of post (registered users only)” field?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Of course you can’t enable “Author of post (registered users only)” because I haven’t enabled it yet. I must have merged it across from my editing work – but it doesn’t do anything. That checkbox is only for editing forms (which is not supported yet) – the idea being to allow Authors of posts edit their own posts. For new posts, you don’t yet have an author! 🙂

    As for Contributors not being able to access the form even though you have all the Roles enabled, is very strange. What are you’re other configurations for access?

    Hi TDO,

    As a temporary workaround I currently I have it set to allow “Unregistered Users (i.e. everyone)” but that’s (obviously) not preferable long term…

    How I had it set was to allow “Users with rights to publish posts”.
    Then I had all 5 boxes checked…. ie:
    Subscriber (newly registered users)
    Contributor
    Editor (can publish posts)
    Author (can publish posts)
    Administrator (can publish posts)

    But – the problem was that Subscribers & Contributors were seeing a message saying: “You don’t have access rights to this form”!
    The strangest thing of all was that the first member to encounter the problem was a “contributor” with the highest TDO post-count!

    Stranger still is that – since I changed settings to allow “Unregistered Users (i.e. everyone)”, he made another post… But when I check the “Manage” link he isn’t listed under “Last 15 Submitters”… In fact – the last 2 users to use the form haven’t been included in the “Manage” list!

    Sorry to hear you were unwell btw… Hope you’re over it now.

    Regards,
    ClickyB

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘TDOMF – Permissions Problem’ is closed to new replies.