Support » Plugin: Gravity Forms - Update Post » taxonomy unchecked Not Saved

  • Resolved anamostafa


    I think you have a problem with Taxonomy check box, it just save the new checked items
    i mean when you choose to remove the checked from any previous selected term within the filed “checkbox” [ Populate with a Taxonomy by gravity form custom post types plugin] the taxonomy field doesn’t save the unchecked items.
    and it appears in the admin area that the user still select this term and didn’t unselected it.

    I’m using
    Wordpress V. 3.4.2
    Gravity Forms + Custom Post Types Version 3.0.1
    Gravity Forms – Update Post Version 0.5.3

    Thank you in advance

Viewing 8 replies - 1 through 8 (of 8 total)
  • anamostafa,

    I am seeing the same problem you described. I also tried using the drop down field (as well as checkboxs) thinking that since only one item can be selected, it would clear the rest. That didn’t work either. It keeps adding a new taxonomy entry every time I select a different entry. It doesn’t remove the previous selection.

    Have you had any luck fixing this problem? Maybe we can figure this out together.

    Hello Srumery
    I saw that you have found the solution in the post

    is every thing is working good now?

    Yes. That little fix did the trick. It should work for you as well.

    it working for me but after changing the same value to false at line 411 for checkbox , thanks man Good Luck

    That’s good to know. I’m glad you got it working!


    Hi all! I know this thread is getting a bit old, but I thought I would see if I can get any additional information on this fix. I have several multi-select areas in a form that are being pre-populated with taxonomies. Unchecking them does not save, even with all the lines mentioned above changed to “false”. I’ve also tried changing them to checkboxes with no luck.

    Any ideas what else I might be able to do to get the taxonomy values to reset and only use what people have selected (or deselected)?


    The link to the form is behind a login, so I apologize for not including it.

    Wow, OK, now I’m embarrassed. Looks like the developer I was working with installed a 4.0 beta version of this plugin where the change wasn’t working. Going back to a stable version fixed everything.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘taxonomy unchecked Not Saved’ is closed to new replies.