Support » Plugin: WP Multilang » Taxonomy term titles not translated & wrong post slugs

  • Resolved Hendrik Lersch

    (@riddler84)


    Hi, i have again a few problems.
    The first one appears after one of the latest updates and concerns the titles of taxonomy terms that shows the untranslated strings in back- and frontend, especially if i use the taxonomy fields of ACF. The normal WP taxonomy boxes on post edit screens shows the translated strings but only the default language.

    Also there are no flags showing the translation status in taxonomy edit screen. But if i switch the language tab, the titles switch to the correct language. But still no flags.

    The second problem concerns the post slugs when i create a new post. It doesn’t matter, if i save the post directly with a title or without, the post slug will always be “auto-draft”. I have to change the title manually every time. This is annoying^^
    This happens only on post types that are configured for translation, so i think there is a connection to your plugin.

    Best regards

Viewing 9 replies - 1 through 9 (of 9 total)
  • Fixed in new version.
    Please update.
    Thank You for your report.

    Thread Starter Hendrik Lersch

    (@riddler84)

    Thank you again for your very fast support and bugfixing!

    Thread Starter Hendrik Lersch

    (@riddler84)

    Oh, just noticed that the flags on the taxonomy overview pages are still missing. The languages column is complete empty.

    Try resave taxonomy.

    Thread Starter Hendrik Lersch

    (@riddler84)

    I have, but still no flags. It’s weird. If i add a new one, which will be dynamically added to the list, then it will show the flag. After a reload of the page the flag is gone. And saving or changing of the already existing terms has no effect, in terms that there is no flag. The rest works fine.

    Can any another plugin make conflict?

    Thread Starter Hendrik Lersch

    (@riddler84)

    Yes, you’re right. It’s because of this: https://github.com/mcguffin/acf-quick-edit-fields

    @riddler84
    This is problem in plugin ACF QuickEdit Fields. It delete any custom columns content. Not only from WP Multilang.

    Thread Starter Hendrik Lersch

    (@riddler84)

    No, that can’t be true. It shows me custom field columns in the posts overview and the language flags are still there, like the custom columns of two other plugins.

    Only the flags on the taxonomy pages disappear. But maybe it depends on the type of the ACF fields, that are displayed in the columns. In my case i have columns for a image and a color field.

    On the posts overview it’s just text from a relationship field.

    Edit:
    Ok, it IS true^^ But only taxonomys are affected. I will try to contact the author of that plugin. Thank you for your help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Taxonomy term titles not translated & wrong post slugs’ is closed to new replies.