Support » Plugin: Custom Post Type UI » Taxonomy slugs interfere with existing pages giving 404

  • Resolved wdwnewstoday

    (@wdwnewstoday)


    I’ve created a custom taxonomy. In it I have a term with the slug “wdw”. Now, all existing pages on the site whose permalinks begin with /wdw give 404 errors, such as wdwnt.com/wdwntunes.

    When I change the permalink on the edit page from domain.com/wdw to something like domain.com/wdwresort, then my page at wdwnt.com/wdwntunes works again.

    This seems like a bug, the permalink for the page is different than the slug, it just happens to begin with the same 3 letters.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • I just confirmed that this happens in other cases as well.
    Example:
    Existing page: wdwnt.com/store
    Create a term in a taxonomy with a slug “sto” and permalink wdwnt.com/sto
    Now existing wdwnt.com/store page no longer works – gives 404.
    Delete “sto” term or change permalink to something else and wdwnt.com/store works again.

    Update: This appears to be an incompatibility with the Permalinks Customizer plugin. When I deactivated that plugin, the Permalink setting box disappears from the taxonomy term edit page. I never would have guessed that the Permalinks Customizer plugin would add a field to the taxonomy page!

    Plugin Author Michael Beckwith

    (@tw2113)

    So to confirm, you feel it’s more an issue with the Permalinks Customizer plugin and not CPTUI, correct?

    I would imagine anything that can be a part of the urls/permalinks, would end up getting fields added to their areas. Taxonomies definitely will.

    Regardless, hopefully you get a solution that covers all things you need for your site.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.