WordPress.org

Support

Support » Plugins and Hacks » Taxonomy Dropdown Not Working for Just One Taxonomy

Taxonomy Dropdown Not Working for Just One Taxonomy

  • Ian

    @ianaleksander

    I need taxonomy dropdowns on my site. I have the following code in a php friendly widget in my sidebar:

    <select style="width:80%;" name="tag-dropdown" onchange="document.location.href=this.options[this.selectedIndex].value;">
    	<option value="#">Character</option>
    	<?php dropdown_tag_cloud('number=0&order=asc'); ?>
    </select>
    <br>
    <select style="width:80%;"  name="tax-term-dropdown" onchange="document.location.href=this.options[this.selectedIndex].value;">
        <option value="#">Series</option>
        <?php dropdown_taxonomy_term('series', 'orderby=name&order=asc&hide_empty=1&number=0'); ?>
    </select>
    <br>
    <select style="width:80%;"  name="tax-term-dropdown" onchange="document.location.href=this.options[this.selectedIndex].value;">
        <option value="#">Creator</option>
        <?php dropdown_taxonomy_term('creator', 'orderby=name&order=asc&hide_empty=1&number=0'); ?>
    </select>
    <br>
    <select style="width:80%;"  name="tax-term-dropdown" onchange="document.location.href=this.options[this.selectedIndex].value;">
        <option value="#">Edition</option>
        <?php dropdown_taxonomy_term('edition', 'orderby=name&order=asc&hide_empty=1&number=0'); ?>
    </select>
    <br>

    Each of the other taxonomies – the tags, categories (in a different section, not the code above) and the taxonomies listed there all work except for “series.”

    That taxonomy works just fine in every other aspect – tagging it, viewing the lists on the site, calling it during posts and on archive views. But not here!

    I don’t get it. Does anyone have any advice?

    You can see the others working fine on the site here:

    http://www.tradereadingorder.com/series/best-of-style-collection/

    this actually is a list generated from this taxonomy, and you can see the tags listed in a non-dropdown format (just showing the top terms) in the inner sidebar.

    this is driving me nuts!

Viewing 1 replies (of 1 total)
  • Ian

    @ianaleksander

    I’m still having this problem. Can anyone advise me on a better way to do it? any ideas?

Viewing 1 replies (of 1 total)
  • The topic ‘Taxonomy Dropdown Not Working for Just One Taxonomy’ is closed to new replies.