Support » Plugin: Ultimate CMS » Taxonomy & custom image field

  • Resolved piwi666



    Thank you for this great plugin !!
    I have an issue when I try to add a picture to my taxonomy.

    With wordpress 3.5.1, when I push the “add image” button, I’m redirected to the new media upload page. I choose my picture and push the “add to post” button.

    I’m redirected to a blank page with this url …/media-upload.php?type=image&tab=type&post_id=0

    Do you have an idea ? I think arguments are missing in the url when redirected to the upload page

    Thank you !!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author XYDAC


    I tried the same on a vanilla install of WP 3.5.1, with my plugin only. there were no such issues. Could you please try disabling other plugins and re testing this.


    confirmed on WP3.5.1, all plugins deactivated but Ultimate CMS (activated: taxonomies only)

    to reproduce:
    – upload one image to your media library
    – create new taxonomy (test-taxo) that applies to “post” type.
    – add new field of type image to test-taxo (logo)
    – choose Posts > Test-Taxo to create new term
    – enter name (test-term), click on “add image” below “logo” fied of test-term
    – open “media library” tab, click on “insert into post” at bottom of page

    -> leads empty page at url to wp-admin/media-upload.php?type=image&tab=library&post_id=0

    what I do for now is copy-paste the image url from the library into the “logo” field, it works but does not respect the proportions of the image, as square thumbnails are displayed in admin view, whereas original image is not square.

    Plugin Author XYDAC


    That’s a weird bug, the thick-box doesn’t seems to be working automatically when only taxonomy are only activated.
    The best workaround right now would be to enable Page types as well.

    Do let me know if it works.

    I’ll try to fix that by next version.


    thanks for looking into it Xydac.

    Activating the “pages” modules changes the flow but does not solve the issue:

    with pages not activated the before-last step above “click on “add image” below “logo” fied” is leading me to a full-page interface (http://localwp/wp-admin/media-upload.php?type=image&TB_iframe=true&width=640&height=513) and clicking on “insert into post”
    raises the following in web console:

    [10:27:51.114] POST http://localwp/wp-admin/media-upload.php?type=image&tab=library&post_id=0 [HTTP/1.1 200 OK 494ms]
    [10:27:51.616] TypeError: win.send_to_editor is not a function @ http://localwp/wp-admin/media-upload.php?type=image&tab=library&post_id=0:4   - media-upload.php:4

    We I do activate the pages module, then thickbox seems to be loaded, as the “image selection” dialog does display as smaller dialog on top of the term page, not full-screen.

    [10:31:51.763] GET http://localwp/wp-includes/js/thickbox/thickbox.css?ver=20121105 [HTTP/1.1 304 Not Modified 0ms]

    but clicking on “insert into post” raises the same error

    [10:34:43.158] POST http://localwp/wp-admin/media-upload.php?type=image&tab=library&post_id=0 [HTTP/1.1 200 OK 433ms]
    [10:34:43.606] TypeError: win.send_to_editor is not a function @ http://localwp/wp-admin/media-upload.php?type=image&tab=library&post_id=0:4

    To be complete, I’m running TwentyTwelve default theme for these tests, with Firefox on Ubuntu Quantal.

    I don’t know what other information to provide to be helpful, just let me know if there’s anything else that you could use.


    any update?
    fixing this bug would be great addition to this nice plugin!

    fyi I worked around the bug by using the “taxonomy image” plugin, works fine, and allows to associate 1 images from library with categories, tags and custom taxonomy terms, if you so wish.


    Plugin Author XYDAC


    This issue has been fixed in latest version
    Kindly update.

    Do let me know in case of any issues.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Taxonomy & custom image field’ is closed to new replies.