Support » Plugin: Intuitive Custom Post Order » Taxonomy Archive Not Displaying Custom Order Set

  • Hi – great plugin! I have used it on many different occasions.

    Here’s my setup:
    I have a custom post type called “Portfolio”
    I have a custom taxonomy called “Industry”
    I have multiple terms within the custom taxonomy of “Industry”

    The issue I’m running into today is the output order of posts on a taxonomy archive page (http://gmcn.balefireadv.com/portfolio/industry/educational/). It appears this taxonomy archive page is outputting posts by Date instead of the custom order.

    /portfolio/industry/educational/
    equals
    custom post type / taxonomy / term /

    For comparison sake: The plugin is doing a wonderful job of outputting the posts in the correct custom order on the main Custom Post Type archive page.
    http://gmcn.balefireadv.com/portfolio/

    How can I get the taxonomy archive page to output the posts in the same custom order as seen on the archive page?

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • I just ran across this problem, and was able to solve it by hooking into pre_get_posts and adding the following lines (after checking to be sure I’m in my taxonomy archive, of course):

    $query->set('orderby' ,'menu_order');
    $query->set('order' ,'ASC');
    • This reply was modified 6 months, 3 weeks ago by  paperleaf.
Viewing 1 replies (of 1 total)
  • The topic ‘Taxonomy Archive Not Displaying Custom Order Set’ is closed to new replies.