Support » Plugins and Hacks » Drafts of Post Revisions » Taxonomies not transferring

  • xave

    (@xave)


    Hiya again

    I’ve been having issues with custom taxonomies on custom post types not transferring to drafts and back to published content.

    I’ve tried the following fix:
    The private function transfer_post_taxonomies in Postdrafter.php I think needs tweak to first line to force the get_object_taxonomy to return as object (rather than default names):
    $taxis = get_object_taxonomies( get_post_type($from_id),’objects’ );

    Is the plugin supposed to do manage custom taxonomies?

    Going to run through a debugger to spot what’s happening here, but would appreciate feedback. cheers 🙂

    http://wordpress.org/extend/plugins/drafts-of-post-revisions/

Viewing 1 replies (of 1 total)
  • Plugin Author daxitude

    (@daxitude)


    Hi there.

    Taxonomies and custom taxonomies are supposed to transfer both ways, and as far as I can tell it works as intended.

    Is taxonomy transfer universally not working for you, or only with certain custom post types and certain custom taxonomies?

    Did the above fix resolve the issue for you? I can’t seem to produce a failing condition, so as yet am unable to diagnose the situation.

    Can you check how you’ve registered the taxonomy and the post type? Are you declaring the taxonomy in the register_post_type function and/or declaring the post type in the register_taxonomy function? If the taxonomy and post type aren’t associated, then the transfer will fail, but then the taxonomy should also not be available in the post edit screens.

    Thanks.

Viewing 1 replies (of 1 total)
  • The topic ‘Taxonomies not transferring’ is closed to new replies.