Support » Plugin: Media Library Assistant » Taxonomies Not Taking

  • Resolved uamv


    i have some strange things happening that are not allowing me to query by taxonomies (attachment_category or attachment_tag). In the assistant, i have assigned taxonomies to the attachment. When i roll over, they show something with regards to mla-tax and mla-term. However, if i go to taxonomy UI, the attachments column shows ‘0’ for all taxonomies! Something is amiss. Is this a known issue? Do you have plans to resolve? My best bet to include in the mla_gallery shortcode currently is to use the ids=”” parameter, but i want to avoid updating this shortcode every time i upload new media. Would love to query on category and tag. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author David Lingren


    Thanks for taking the time to post this question. Let me make sure that I understand your issue.

    You have assigned attachment_category and _attachment_tag terms to your attachments, and these are showing up in the “Att. Categories” and “Att. Tags” columns of the Media/Assistant screen. When you roll over the values in those columns you can see the mla-tax and mla-term arguments in the links behind each term. However, when you go to the Media/Att. Category or Media/Att. Tag screens, the Attachments column on those screens shows ‘0’ (no attachments) for all the terms you have assigned. Is that right?

    I haven’t been able to re-create this issue on my test site; the Attachments column is working for me. I hope you can give me more information to go on.

    1. If you click on a link in the “Att. Categories” and “Att. Tags” columns of the Media/Assistant screen you should get back a list of the attachments that have that term. Does that work, i.e., are the attachments with that term listed on the screen?
    2. If you click on the ‘0’ in the Attachments column of the taxonomy screens you should get back a list of the attachments with that term. Does that work, i.e., are the attachments with that term listed on the Media/Assistant screen?
    3. Do you see the terms on the Edit Media screen and the quick edit area?
    4. Have you tried using taxonomy and/or tag parameters in an [mla_gallery] shortcode to display a gallery of attachments with a specific term? If so, did that work?
    5. What version of WordPress are you using (the topic says 3.5)?

    Answers to those questions will help me investigate the issue. Thanks for your patience!

    You described my issue correctly. Let me first say, i am using the Role Scoper plugin, and Easy Content Types plugin, which both have some relationship with taxonomies … not sure if there may be conflict anywhere there.

    1. When i click on those links … i get ‘No items found.’
    2. Clicking on the ‘0’ also give ‘No items found.’
    3. The terms do appear on both the edit media screen and quick edit.
    4. i have tried using [mla_gallery attachment_category=”], [mla_gallery attachment_tag=”], and [mla_gallery tax_query=”]
    5. Yup, on 3.5

    Let me know if i can do anything to assist.

    Plugin Author David Lingren


    Thanks for the additional information!

    Role Scoper has caused trouble in the past:

    [mla_gallery] working only for the author

    I posted to the Role Scoper support forum 2 months ago, but have not received any response. It’s possible that updates to Role Scoper since then have created new interaction issues. I have not tested Easy Content Types. I will do some testing with both of these plugins and see what I can find.

    By the way, I don’t see “Easy Content Types” in the WordPress directory – is that the exact name? Can you tell me the author or give me a link?

    If it’s possible, try temporarily deactivating one or both of those plugins and see if the problem goes away. If it does, re-activate them one at a time and see when the problem returns. That would be a clue…

    If you’re feeling adventurous, try adding mla_debug=true to one or more of your [mla_gallery] shortcodes. You should see a lot of debugging information added to the post/page containing the gallery. Don’t do this on a public/production site – it’s pretty ugly!

    If you get some debugging results I’d love to see them. If you’re willing to do that or you have other information you don’t want to post here, go to the Our Story/Contact Us ( page at and give me your e-mail address. I’ll send you my e-mail address and we can exchange more information.

    Thanks again for using the Media Library Assistant and for your patience while I work on this issue.

    i contacted you at the above address with some mla_debug results.

    Plugin Author David Lingren


    Thank you for sending the mla_debug results; very helpful!

    It looks like the Easy Custom Content Types (ECCT) plugin is modifying the SQL statements that Media Library Assistant uses for the Attachment column and for the [mla_gallery] shortcode queries. In particular, it is modifying the post_type clause and eliminating attachments from consideration.

    I posted a query to the ECCT support forum and have received this reply:

    Pippin Williamson wrote:

    To resolve the problem, have your user go to Content Types > Settings > and check the box that says “Disable Taxonomy Archive Fix”.

    Post Link: Conflict between Easy Custom Content Types and Media Library Assistant

    Could you follow Pippin’s directions and see if they resolve your iaaue? Thanks for your help and for your patience.

    David –

    Made that setting change and all seems to be working okay with taxonomy queries. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Taxonomies Not Taking’ is closed to new replies.