WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Taxonomy terms disappearing after filtering, is this normal?

[Resolved] Taxonomy terms disappearing after filtering, is this normal?

  • Hi, thanks for this. Looks to be great for my needs but I don’t think it’s working properly for me, unless this is default behaviour.

    I’ve inserted the widget into my sidebar and I can see my custom taxonomy terms in the list. When I click on one of the taxonomy terms, it loads the next page, shows me the search results but the terms all disappear and I’m left with just the reset link underneath the taxonomy title.

    Are the terms supposed to disappear? I would imagine you should be able to clear it by clicking a minus sign next to it. Sounds like something has gone wrong on my end.

    Any idea what’s happening?

Viewing 9 replies - 1 through 9 (of 9 total)
  • EDIT: Fixed the below. Deleted it, cleared cache and tried again. Unsure on the missing terms still.

    Just noticed that my “locations” taxonomy terms aren’t working at all, but the “services” are. Weird because they are exactly the same (just copied/pasted and edited the names).

    I’ve double checked there is a location on a post, flushed permalinks, tried without other plugins installed & tried the taxonomy by itself.

    No strange php errors or anything in firefox error console. Page just shows:

    “Sorry, no posts matched your criteria.”

    Ok saw the screenshots, I’m definately missing the terms with the “-” next to them 🙂

    Something else that I’ve noticed also is that the terms don’t line up next to the checkboxes on the widget itself. On the screenshot they are perfectly aligned, mine are about 8-10 pixels offset.

    Plugin Author scribu

    @scribu

    The alignment is something you’ll have to fix in your theme’s CSS.

    Not sure what could be causing the missing terms.

    Ok thanks, I’ll keep trying.

    The misalignment of the checkboxes etc is on the widget itself in WP and not on the front end.

    Ok I’m close… My theme is running on Genesis and I was calling the widget in a custom sidebar I had registered. I have now moved the widget into the primary sidebar and called the primary sidebar from my template and also set up some tags and categories.

    The plugin is working now with tags and categories but not with my custom taxonomies still so I must be doing something wrong, maybe missing a setting or something.

    Plugin Author scribu

    @scribu

    The misalignment of the checkboxes etc is on the widget itself in WP and not on the front end.

    I see. Could you post a screenshot? Maybe some other plugin is interfering.

    Hi, I have the same problem.
    Im using this code to put widget in and it worked before the last update

    <?php the_widget('Taxonomy_Drill_Down_Widget', array(
            'title' => '',
            'mode' => 'dropdowns',
            'taxonomies' => array( 'tax1', 'tax2', 'tax3', 'tax4') // list of taxonomy names
    )); ?>

    I disabled all other plugins but that did not help.

    Also, is it possible to have one of taxonomies “excluded” from drilldown so you always have all the terms from that taxonomy in dropdown?

    Thanx for the great plugin.

    I setup a new site with no plugins installed, used the twenty ten theme (to make sure Genesis wasn’t causing any issues) and then registered my taxonomies, added a few posts, set up the taxonomy.php and then tested. Terms for my custom taxonomies still won’t show up but they work fine for tags and categories and I can see the minus signs as before. Also tried using a plugin to register the taxonomies (easy post types I believe) but still no luck. Thought there was something wrong in the way I was setting them up.

    Here’s a screenshot of the widget that is misaligned for me.
    http://cl.ly/1K1h0o1F1Q0G1W0p0C0t

    Hi Scribu. Just wanted to say thanks for the recent update. Works beautifully now

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Taxonomy terms disappearing after filtering, is this normal?’ is closed to new replies.