Support » Plugin: Pricing Deals for WooCommerce » Taxes do not work anymore

  • Resolved barthdesigns

    (@barthdesigns)


    Hello,
    I’ve downloaded the free version to test. It’s just one thing that I can not use it as it does not let me to select the product I wish to add the discount for.

    But the big problem is: since installed plugin (and even after deactivation and uninstallation) my tax settings are ruined. Before installing it worked fine and now I see that 0% tax is added. Somehow it works in reverse as it should: if I click enable taxind than it does 0%, and if I click do not add VAT, it adds my pre-defined VAT percent.

    Looks like VAT is somehow mixed with discounts.

    If i change my pre.defined 27% in flat taxing, than the lower I make it the bigger is the “normal” VAT included price on all products.

    Please help solve this problem! Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author vark

    (@vark)

    Hi,
    Pricing Deals accesses taxation settings using standard Woo access methods.

    There is nothing in Pricing Deals which updates taxation.

    The fact that your issue remains after deactivation and deletion of the Pricing Deals plugin, indicates strongly that something else is causing your problem.

    Suggest a full module conflict test (**without** Pricing Deals installed!!)

    To track down a module conflict, please follow these steps ** PRECISELY **:
    (1) Install and activate a maintenance mode plugin (if desired)
    (2) Then, DO ALL (*at the same time*):
    (-) do a full site backup!
    (-) deactivate ***all*** plugins except Woo (and maintenance mode plugin)
    (-) ** switch to a clean default theme like 2017 **
    — (This removes all other possible conflicts.)
    (-) turn off all deals except the one we are examining.

    (3) ** test **
    (4) if good, add 1 module back in. ** Retest **
    (5) Repeat until conflict identified.

    ** This test depends on following the outlined steps fully. **

    Best,
    Vark

    Hello Vark,

    Thank you for your super quick reply!

    It is very strange as last evening everything was fine. This morning I wanted to install a plugin that lets me do bulk discount for 10 units of a specific product. I’ve found your plugin, let’s try it.

    Installed, and I just noticed I can not use this plugin for what I would like.

    So I uninstalled. And when visited my shop I see there is 0% VAT on everything, even though other taxing settins did not change.

    Should I let you in for a check?

    Tried to deactivate all other plugins, did not help.

    Thanks,
    J.

    Plugin Author vark

    (@vark)

    Hi,
    Unfortunately, as Pricing Deals can’t be responsible for the issue, there’s nothing I can do for you, beyond suggesting you restore your system from your backups, to a time when it was uncorrupted.
    Best,
    Mark

    Hi Mark,

    And do you have any other ideas? I’m helpless 🙁
    J.

    Plugin Author vark

    (@vark)

    Hi,

    You know when the issue began….

    Call your host and ask to restore your system using their backups.

    Restore using backups made before the issue began.

    Yep, the issue began with your plugin 🙂 Not joking, it worked before.

    Problem solved, by the way: I used the Tools inside WC settings and cleared everything. That solved the problem.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Taxes do not work anymore’ is closed to new replies.